summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 21:11:38 +0200
committerDavid Craven <david@craven.ch>2016-08-18 13:06:19 +0200
commit8ff1dabe1e6243e80d2a06e173bdf1ec6aeebcac (patch)
treebe01b0de06f4dd0515eff6650ed745212e45a990
parentb05eb5dd27c7155e644a0925fedf05815428fb85 (diff)
downloadpatches-8ff1dabe1e6243e80d2a06e173bdf1ec6aeebcac.tar
patches-8ff1dabe1e6243e80d2a06e173bdf1ec6aeebcac.tar.gz
gnu: Add kimageformats.
* gnu/packages/kde-frameworks.scm (kimageformats): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 0c3e8098eb..eeedbddb1e 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1225,3 +1225,40 @@ text and metadata from a number of different files. This library is typically
used by file indexers to retreive the metadata. This library can also be used
by applications to write metadata.")
(license (list license:lgpl2.0 license:lgpl2.1 license:lgpl3))))
+
+(define-public kimageformats
+ (package
+ (name "kimageformats")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "12mhgckmhnvcnm8k7mk15mipxrnm7i9ip7ykbjh8nxjiwyk1pmwc"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("xorg-server" ,xorg-server)))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'start-xorg-server
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The test suite requires a running X server.
+ (system (string-append (assoc-ref inputs "xorg-server")
+ "/bin/Xvfb :1 &"))
+ (setenv "DISPLAY" ":1")
+ #t)))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Plugins to allow QImage to support extra file formats")
+ (description "This framework provides additional image format plugins for
+QtGui. As such it is not required for the compilation of any other software,
+but may be a runtime requirement for Qt-based software to support certain image
+formats.")
+ (license license:lgpl2.1+)))