summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 21:13:55 +0200
committerDavid Craven <david@craven.ch>2016-08-18 13:06:20 +0200
commit812bab6ded125ecb304db3f473305b5127bb8556 (patch)
tree5293feb45044e59fbecd15c3eed82ae40905306b
parentfee9b2662ed625432a6ed09e481fb436ebe335e9 (diff)
downloadpatches-812bab6ded125ecb304db3f473305b5127bb8556.tar
patches-812bab6ded125ecb304db3f473305b5127bb8556.tar.gz
gnu: Add kunitconversion.
* gnu/packages/kde-frameworks.scm (kunitconversion): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 36097cc267..866529f91b 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1406,3 +1406,30 @@ were traditional plugins.")
terminal devices as well as a KProcess derived class for running child processes
and communicating with them using a pty.")
(license (list license:gpl2+ license:lgpl2.1+))))
+
+(define-public kunitconversion
+ (package
+ (name "kunitconversion")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "03dfjn4lm6sl2zcdrvw0b9irzvkyc2w2j5xixag5j8nw373742h8"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("ki18n" ,ki18n)
+ ("qtbase" ,qtbase)))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Converting physical units")
+ (description "KUnitConversion provides functions to convert values in
+different physical units. It supports converting different prefixes (e.g. kilo,
+mega, giga) as well as converting between different unit systems (e.g. liters,
+gallons).")
+ (license license:lgpl2.1+)))