summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 21:09:07 +0200
committerDavid Craven <david@craven.ch>2016-08-18 13:06:18 +0200
commit46c27be120b39fc7ac13e66afa318714b1d1f85c (patch)
tree6f6c4d4bf2109bdf7f433fe65324603a4ff860ca
parent689bb11a346216e319f2cb66e5a9e9cc8c670655 (diff)
downloadpatches-46c27be120b39fc7ac13e66afa318714b1d1f85c.tar
patches-46c27be120b39fc7ac13e66afa318714b1d1f85c.tar.gz
gnu: Add kauth.
* gnu/packages/kde-frameworks.scm (kauth): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 875d94aa1c..ca57e58125 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -34,6 +34,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages python)
#:use-module (gnu packages qt)
#:use-module (gnu packages xorg))
@@ -1020,3 +1021,45 @@ ASpell and HUNSPELL.")
(description "ThreadWeaver is a helper for multithreaded programming. It
uses a job-based interface to queue tasks and execute them in an efficient way.")
(license license:lgpl2.1+)))
+
+
+;; Tier 2
+;;
+;; Tier 2 frameworks additionally depend on tier 1 frameworks, but still have
+;; easily manageable dependencies.
+
+(define-public kauth
+ (package
+ (name "kauth")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "14sjjfgl3arqyqcr77w9qhpnd8mrnh53r5rfss6bvlk26bmihs49"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("dbus" ,dbus)
+ ("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("kcoreaddons" ,kcoreaddons)
+ ("polkit-qt" ,polkit-qt)
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* _
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (zero? (system* "dbus-launch" "ctest" ".")))))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Execute actions as privileged user")
+ (description "KAuth provides a convenient, system-integrated way to offload
+actions that need to be performed as a privileged user to small set of helper
+utilities.")
+ (license license:lgpl2.1+)))