summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 21:09:42 +0200
committerDavid Craven <david@craven.ch>2016-08-18 13:06:18 +0200
commit13094df1edcf41428d253ced1f63a894e43e3ddb (patch)
tree642e05262d34bacd3a5eb0cbb1a4c116ed01cb5f
parent46c27be120b39fc7ac13e66afa318714b1d1f85c (diff)
downloadpatches-13094df1edcf41428d253ced1f63a894e43e3ddb.tar
patches-13094df1edcf41428d253ced1f63a894e43e3ddb.tar.gz
gnu: Add kcompletion.
* gnu/packages/kde-frameworks.scm (kcompletion): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index ca57e58125..572edb87cc 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1063,3 +1063,45 @@ uses a job-based interface to queue tasks and execute them in an efficient way."
actions that need to be performed as a privileged user to small set of helper
utilities.")
(license license:lgpl2.1+)))
+
+(define-public kcompletion
+ (package
+ (name "kcompletion")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1qln0v31gn86kzwhnkijr1ydf129n32jmiybbckrp4w6hyx6xfxv"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)
+ ("xorg-server" ,xorg-server)))
+ (inputs
+ `(("kconfig" ,kconfig)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda* _
+ (setenv "DBUS_FATAL_WARNINGS" "0")))
+ (add-before 'check 'start-xorg-server
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The test suite requires a running X server.
+ (system (string-append (assoc-ref inputs "xorg-server")
+ "/bin/Xvfb :1 &"))
+ (setenv "DISPLAY" ":1")
+ #t)))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Powerful autocompletion framework and widgets")
+ (description "This framework helps implement autocompletion in Qt-based
+applications. It provides a set of completion-ready widgets, or can be
+integrated it into your application's other widgets.")
+ (license license:lgpl2.1+)))