summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 21:12:41 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:11 +0200
commit08c3993f4f4cdb323aa79bc7de6dce6a6324050d (patch)
tree6789ad098de7793e5667a6a086d5baf275c13124
parent44f717efff4b2d789597ee00b94f0d12dd4df1bc (diff)
downloadpatches-08c3993f4f4cdb323aa79bc7de6dce6a6324050d.tar
patches-08c3993f4f4cdb323aa79bc7de6dce6a6324050d.tar.gz
gnu: ghc-th-lift: Update to 0.7.11.
* gnu/packages/haskell.scm (ghc-th-lift): Update to 0.7.11. [inputs]: Add ghc-th-abstraction.
-rw-r--r--gnu/packages/haskell.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7d59b5ada5..63a7825ed4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5622,15 +5622,17 @@ Template Haskell.")
(define-public ghc-th-lift
(package
(name "ghc-th-lift")
- (version "0.7.8")
+ (version "0.7.11")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"th-lift/th-lift-" version ".tar.gz"))
(sha256
(base32
- "0ay10b78x3969rpqqrgzy8srkl6iby2cljbf3mm17na8x22k7y1c"))))
+ "131360zxb0hazbqwbkk6ab2p77jkxr79bwwm618mrwrwkm3x2g6m"))))
(build-system haskell-build-system)
+ (inputs
+ `(("ghc-th-abstraction" ,ghc-th-abstraction)))
(home-page "https://github.com/mboes/th-lift")
(synopsis "Derive Template Haskell's Lift class for datatypes")
(description