summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-11-30 18:31:37 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-11-30 18:31:37 +0100
commitbc118f1a0367036128a6acfdc9fe34c8554009ac (patch)
tree28fbbeb9cfccb13269d3c6b70b3b0cc314583db9
parent8b6aee5f82461f43a3ff4f12ccb84ae87413b112 (diff)
downloadpatches-bc118f1a0367036128a6acfdc9fe34c8554009ac.tar
patches-bc118f1a0367036128a6acfdc9fe34c8554009ac.tar.gz
gnu: cairo: Eliminate graft.
* gnu/packages/gtk.scm (cairo)[replacement]: Remove field. [source]: Add patch from 'cairo/fixed'. (cairo-xcb)[source]: Inherit from cairo. [replacement]: Remove field. (cairo/fixed): Remove variable. * gnu/packages/pdf.scm (poppler)[inputs]: Remove cairo replacement.
-rw-r--r--gnu/packages/gtk.scm15
-rw-r--r--gnu/packages/pdf.scm11
2 files changed, 2 insertions, 24 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 224e33e711..b1a8e272db 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -100,7 +100,6 @@ tools have full access to view and control running applications.")
(define-public cairo
(package
(name "cairo")
- (replacement cairo/fixed)
(version "1.14.6")
(source (origin
(method url-fetch)
@@ -108,7 +107,8 @@ tools have full access to view and control running applications.")
version ".tar.xz"))
(sha256
(base32
- "0lmjlzmghmr27y615px9hkm552x7ap6pmq9mfbzr6smp8y2b6g31"))))
+ "0lmjlzmghmr27y615px9hkm552x7ap6pmq9mfbzr6smp8y2b6g31"))
+ (patches (search-patches "cairo-CVE-2016-9082.patch"))))
(build-system gnu-build-system)
(propagated-inputs
`(("fontconfig" ,fontconfig)
@@ -154,10 +154,6 @@ affine transformation (scale, rotation, shear, etc.).")
(package
(inherit cairo)
(name "cairo-xcb")
- (source (origin
- (inherit (package-source cairo))
- (patches (search-patches "cairo-CVE-2016-9082.patch"))))
- (replacement #f)
(inputs
`(("mesa" ,mesa)
,@(package-inputs cairo)))
@@ -167,13 +163,6 @@ affine transformation (scale, rotation, shear, etc.).")
'("--enable-xlib-xcb" "--enable-gl" "--enable-egl")))
(synopsis "2D graphics library (with X11 support)")))
-(define cairo/fixed
- (package
- (inherit cairo)
- (source (origin
- (inherit (package-source cairo))
- (patches (search-patches "cairo-CVE-2016-9082.patch"))))))
-
(define-public harfbuzz
(package
(name "harfbuzz")
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index b95fe5e0cf..d491642e49 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -95,17 +95,6 @@
;; To build poppler-glib (as needed by Evince), we need Cairo and
;; GLib. But of course, that Cairo must not depend on Poppler.
("cairo" ,(package (inherit cairo)
- (replacement
- (package
- (inherit cairo)
- (replacement #f)
- (source
- (origin
- (inherit (package-source cairo))
- (patches (search-patches
- "cairo-CVE-2016-9082.patch"))))
- (inputs (alist-delete "poppler"
- (package-inputs cairo)))))
(inputs (alist-delete "poppler"
(package-inputs cairo)))))
("glib" ,glib)))