summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-20 21:51:49 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-25 15:38:17 +0100
commitbd4464f2e910dac5cada57acd3788aff50f8583e (patch)
tree5f0f80981140ca7c73d06d7e9a6c532e280e1d2d
parent49f367088983e2643f710479cb84a10087a5bd31 (diff)
downloadpatches-bd4464f2e910dac5cada57acd3788aff50f8583e.tar
patches-bd4464f2e910dac5cada57acd3788aff50f8583e.tar.gz
gnu: Add portaudio.
* gnu/packages/audio.scm (portaudio): New variable.
-rw-r--r--gnu/packages/audio.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index aba5b5a61c..52feea3701 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -867,3 +867,32 @@ conversion. It may be used, for example, to resample PCM-encoded audio.")
tooLAME by Mike Cheng, which in turn is based upon the ISO dist10 code and
portions of LAME.")
(license license:lgpl2.1+)))
+
+(define-public portaudio
+ (package
+ (name "portaudio")
+ (version "19.20140130")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.portaudio.com/archives/pa_stable_v"
+ (string-map (lambda (c) (if (char=? c #\.) #\_ c)) version)
+ ".tgz"))
+ (sha256
+ (base32 "0mwddk4qzybaf85wqfhxqlf0c5im9il8z03rd4n127k8y2jj9q4g"))))
+ (build-system gnu-build-system)
+ (inputs
+ ;; TODO: Add ASIHPI.
+ `(("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (arguments '(#:tests? #f)) ;no 'check' target
+ (home-page "http://www.portaudio.com/")
+ (synopsis "Audio I/O library")
+ (description
+ "PortAudio is a portable C/C++ audio I/O library providing a simple API
+to record and/or play sound using a callback function or a blocking read/write
+interface.")
+ (license license:expat)))