summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-20 21:44:57 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-25 15:38:17 +0100
commit754a98ae42c490b4c07dbfa8c781395c5896ea4a (patch)
tree8c21fb04ba9dc893d56b17f7483a2f4c209a9eb4
parent9f1cdd9dfabddec447cd5d82d0d5c791601eef9d (diff)
downloadpatches-754a98ae42c490b4c07dbfa8c781395c5896ea4a.tar
patches-754a98ae42c490b4c07dbfa8c781395c5896ea4a.tar.gz
gnu: Add soundtouch.
* gnu/packages/audio.scm (soundtouch): New variable.
-rw-r--r--gnu/packages/audio.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 0e0310b720..e16187701f 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages file)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
@@ -780,3 +781,41 @@ stretching and pitch scaling of audio. This package contains the library.")
;; There is no explicit declaration of a license, but a COPYING file
;; containing gpl2.
(license license:gpl2)))
+
+(define-public soundtouch
+ (package
+ (name "soundtouch")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "http://www.surina.net/soundtouch/soundtouch-" version ".tar.gz"))
+ (sha256
+ (base32 "0sqn3wk4qz20vf0vz853l6dl1gnj1yhqxfwxqsc5lp529kbn2h9x"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("file" ,file)))
+ (arguments
+ '(#:phases
+ (alist-cons-before
+ 'configure 'bootstrap
+ (lambda _
+ (unless (zero? (system* "sh" "bootstrap"))
+ (error "bootstrap failed"))
+ (substitute* '("configure")
+ (("/usr/bin/file") "file")))
+ %standard-phases)))
+ (home-page "http://www.surina.net/soundtouch/")
+ (synopsis
+ "Audio processing library for changing tempo, pitch and playback rate")
+ (description
+ "SoundTouch is an audio processing library for changing the tempo, pitch
+and playback rates of audio streams or audio files. It is intended for
+application developers writing sound processing tools that require tempo/pitch
+control functionality, or just for playing around with the sound effects.")
+ (license license:lgpl2.1+)))