summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2019-08-19 17:28:22 +0530
committerArun Isaac <arunisaac@systemreboot.net>2019-08-30 00:34:10 +0530
commit0f3624f8bc102cd729bcd887a171c5588b397c5b (patch)
tree724dd09e1203f7804d8e0d2109bd3d39216a7aa2
parente30bdd49a5909749baab9fcf566e14e4aac22ccb (diff)
downloadpatches-0f3624f8bc102cd729bcd887a171c5588b397c5b.tar
patches-0f3624f8bc102cd729bcd887a171c5588b397c5b.tar.gz
gnu: Add poussetaches.
* gnu/packages/web.scm (poussetaches): New variable.
-rw-r--r--gnu/packages/web.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 9b2be15e20..52ff9a804e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -68,6 +68,7 @@
#:use-module (guix build-system python)
#:use-module (guix build-system ant)
#:use-module (guix build-system scons)
+ #:use-module (guix build-system go)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages adns)
@@ -92,6 +93,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnu-doc)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -6597,3 +6599,35 @@ It's also possible to rewrite existing log files.
Anonip can also be uses as a Python module in your own Python application.")
(license license:bsd-3)))
+
+(define-public poussetaches
+ (package
+ (name "poussetaches")
+ (version "0.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tsileo/poussetaches")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07106kfcz3a39jvrv3mlqqxlihsmdhgkrjnqznyjsij9absgvdv6"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ `(("go-github-com-robfig-cron" ,go-github-com-robfig-cron)
+ ("go-golang-org-x-time-rate" ,go-golang-org-x-time-rate)))
+ (arguments
+ `(#:import-path "github.com/tsileo/poussetaches"))
+ (home-page "https://github.com/tsileo/poussetaches")
+ (synopsis "Lightweight asynchronous task execution service")
+ (description "Poussetaches (which literally means \"push tasks\" in
+French) is a lightweight asynchronous task execution service that aims to
+replace Celery and RabbitMQ for small Python applications.
+
+The app posts base64-encoded payload to poussetaches and specifies the
+endpoint that will be used to trigger the task. Poussetaches makes HTTP
+requests with the registered payload until the right status code is
+returned.")
+ (license license:isc)))