summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-15 00:27:15 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-29 22:59:28 +0100
commitc5a05e31437d640647b5aa1dd70917149bb3f1a3 (patch)
treebdea8875fadae2c4566d4262d346bb1b25875f7f
parent9820a6d4a0fb82cd97f62ada764af658a4a3e71d (diff)
downloadpatches-c5a05e31437d640647b5aa1dd70917149bb3f1a3.tar
patches-c5a05e31437d640647b5aa1dd70917149bb3f1a3.tar.gz
gnu: python: Factorize configure flags with minimal variants.
* gnu/packages/python.scm (python2-minimal, python-minimal)[arguments]: Reuse the inherited configure flags, and just add --without-system-ffi.
-rw-r--r--gnu/packages/python.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fa8f203828..fd3e6b312b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -247,10 +247,8 @@ data types.")
(name "python-minimal")
(arguments
(substitute-keyword-arguments (package-arguments python-2)
- ((#:configure-flags _)
- `(list "--enable-shared"
- (string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib")))))
+ ((#:configure-flags cf)
+ `(append ,cf '("--without-system-ffi")))))
(inputs '()))) ;none of the optional dependencies
(define-public python-minimal
@@ -258,10 +256,8 @@ data types.")
(name "python-minimal")
(arguments
(substitute-keyword-arguments (package-arguments python)
- ((#:configure-flags _)
- `(list "--enable-shared"
- (string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib")))))
+ ((#:configure-flags cf)
+ `(append ,cf '("--without-system-ffi")))))
;; OpenSSL is a mandatory dependency of Python 3.x, for urllib;
;; zlib is required by 'zipimport', used by pip.