summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-01-17 11:42:29 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-17 13:44:39 +0100
commitc5eedf80ac0d543f15229a58f7d90832b435b28f (patch)
treec345f731806cbfcb9af371aa131407a09ddca211
parent34f9b5814c99b4437997613d3935e4dc1c599fe2 (diff)
downloadpatches-c5eedf80ac0d543f15229a58f7d90832b435b28f.tar
patches-c5eedf80ac0d543f15229a58f7d90832b435b28f.tar.gz
gnu: Add cl-async-future.
* gnu/packages/lisp-xyz.scm (sbcl-cl-async-future, cl-async-future, ecl-cl-async-future): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2033a3e65c..ad28cd7157 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9626,3 +9626,38 @@ the successor to the now-deprecated cl-async-future project.")
(define-public ecl-blackbird
(sbcl-package->ecl-package sbcl-blackbird))
+
+(define-public sbcl-cl-async-future
+ (let ((commit "ee36c22a69a9516407458d2ed8b475f1fc473959")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-async-future")
+ (version (git-version "0.4.4.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/orthecreedence/cl-async-future.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z0sc7qlzzxk99f4l26zp6rai9kv0kj0f599sxai5s44p17zbbvh"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("blackbird" ,sbcl-blackbird)))
+ (native-inputs
+ `(("cl-async" ,sbcl-cl-async)
+ ("eos" ,sbcl-eos)))
+ (synopsis "Futures implementation for Common Lisp")
+ (description
+ "This is futures implementation for Common Lisp. It plugs in nicely
+to cl-async.")
+ (home-page "http://orthecreedence.github.io/cl-async/future")
+ (license license:expat))))
+
+(define-public cl-async-future
+ (sbcl-package->cl-source-package sbcl-cl-async-future))
+
+(define-public ecl-cl-async-future
+ (sbcl-package->ecl-package sbcl-cl-async-future))