summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-01-17 11:30:49 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-17 13:44:39 +0100
commit34f9b5814c99b4437997613d3935e4dc1c599fe2 (patch)
tree48c96c610a3ce7bbdaf392e957c38cc15c4aab64
parentae51aa9136013cdf63efd1f7906668d6d011d4f3 (diff)
downloadpatches-34f9b5814c99b4437997613d3935e4dc1c599fe2.tar
patches-34f9b5814c99b4437997613d3935e4dc1c599fe2.tar.gz
gnu: Add cl-blackbird.
* gnu/packages/lisp-xyz.scm (sbcl-blackbird, cl-blackbird, ecl-blackbird): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c4e27e1507..2033a3e65c 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9591,3 +9591,38 @@ Common Lisp. It uses the libuv library as backend.")
(define-public ecl-cl-async-ssl
(sbcl-package->ecl-package sbcl-cl-async-ssl))
+
+(define-public sbcl-blackbird
+ (let ((commit "d361f81c1411dec07f6c2dcb11c78f7aea9aaca8")
+ (revision "1"))
+ (package
+ (name "sbcl-blackbird")
+ (version (git-version "0.5.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/orthecreedence/blackbird.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xfds5yaya64arzr7w1x38karyz11swzbhxx1afldpradj9dh19c"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("vom" ,sbcl-vom)))
+ (native-inputs
+ `(("cl-async" ,sbcl-cl-async)
+ ("fiveam" ,sbcl-fiveam)))
+ (synopsis "Promise implementation for Common Lisp")
+ (description
+ "This is a standalone promise implementation for Common Lisp. It is
+the successor to the now-deprecated cl-async-future project.")
+ (home-page "http://orthecreedence.github.io/blackbird/")
+ (license license:expat))))
+
+(define-public cl-blackbird
+ (sbcl-package->cl-source-package sbcl-blackbird))
+
+(define-public ecl-blackbird
+ (sbcl-package->ecl-package sbcl-blackbird))