summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-11-25 15:29:08 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-11-26 10:29:29 +0100
commitd3eff97afd08ae2976a3aa80760ef2ba8025e1d6 (patch)
tree03e959042b34ae5a162e9c106d952f2eae616f9e
parentfc5dc4e81cacc4e0dcd81863e505ce5b314264c6 (diff)
downloadpatches-d3eff97afd08ae2976a3aa80760ef2ba8025e1d6.tar
patches-d3eff97afd08ae2976a3aa80760ef2ba8025e1d6.tar.gz
gnu: Add python-polib.
* gnu/packages/python.scm (python-polib, python2-polib): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5e8956f946..83ef3727f8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016 Julien Lepiller <julien@lepiller.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1426,6 +1427,31 @@ backported for previous versions of Python from 2.4 to 3.3.")
syntax.")
(license license:x11)))
+(define-public python-polib
+ (package
+ (name "python-polib")
+ (version "1.0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "polib" version))
+ (sha256
+ (base32
+ "1pq2hbm3m2q0cjdszk8mc4qa1vl3wcblh5nfyirlfnzb2pcy7zss"))))
+ (build-system python-build-system)
+ (home-page "https://bitbucket.org/izi/polib/wiki/Home")
+ (synopsis "Manipulate, create and modify gettext files")
+ (description "Polib can manipulate any gettext format (po, pot and mo)
+files. It can be used to create po files from scratch or to modify
+existing ones.")
+ (license license:expat)))
+
+(define-public python2-polib
+ (let ((base (package-with-python2 (strip-python2-variant python-polib))))
+ (package
+ (inherit base)
+ (arguments `(,@(package-arguments base)
+ ;; Tests don't work with python2.
+ #:tests? #f)))))
(define-public scons
(package