summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-11-24 11:55:15 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-24 21:43:47 +0100
commit62126576fc7f6009682629b5a24d4527a9a09dfa (patch)
tree1f08eabe438a963a6e586d71e93e5018d91467ec
parent6f09c100d90590ca4914a9fe78908dbbbb0850c6 (diff)
downloadpatches-62126576fc7f6009682629b5a24d4527a9a09dfa.tar
patches-62126576fc7f6009682629b5a24d4527a9a09dfa.tar.gz
gnu: hdf5: Build the C++ interface.
* gnu/packages/maths.scm (hdf5)[arguments]: Add #:configure-flags.
-rw-r--r--gnu/packages/maths.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0c51f6d54f..e432ed5c05 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -563,7 +563,10 @@ incompatible with HDF5.")
(inputs
`(("zlib" ,zlib)))
(arguments
- `(#:phases
+ `(;; Some of the users, notably Flann, need the C++ interface.
+ #:configure-flags '("--enable-cxx")
+
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-configure
(lambda _