summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-11-26 14:59:30 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-11-26 20:15:37 +1000
commit31a9d653ad37c9f00b601cfe4a95d90c35c09223 (patch)
tree898b6d457b64375e1d66ada2eb018aefad33fcea
parentd3eff97afd08ae2976a3aa80760ef2ba8025e1d6 (diff)
downloadpatches-31a9d653ad37c9f00b601cfe4a95d90c35c09223.tar
patches-31a9d653ad37c9f00b601cfe4a95d90c35c09223.tar.gz
gnu: Add proteinortho.
* gnu/packages/bioinformatics.scm (proteinortho): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 773b5909b6..308931f3d8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3693,6 +3693,58 @@ for sequences to be aligned and then, simultaneously with the alignment,
predicts the locations of structural units in the sequences.")
(license license:gpl2+)))
+(define-public proteinortho
+ (package
+ (name "proteinortho")
+ (version "5.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "http://www.bioinf.uni-leipzig.de/Software/proteinortho/proteinortho_v"
+ version "_src.tar.gz"))
+ (sha256
+ (base32
+ "05wacnnbx56avpcwhzlcf6b7s77swcpv3qnwz5sh1z54i51gg2ki"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ ;; There is no configure script, so we modify the Makefile directly.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("INSTALLDIR=.*")
+ (string-append
+ "INSTALLDIR=" (assoc-ref outputs "out") "/bin\n")))
+ #t))
+ (add-before 'install 'make-install-directory
+ ;; The install directory is not created during 'make install'.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (mkdir-p (string-append (assoc-ref outputs "out") "/bin"))
+ #t))
+ (add-after 'install 'wrap-programs
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((path (getenv "PATH"))
+ (out (assoc-ref outputs "out"))
+ (binary (string-append out "/bin/proteinortho5.pl")))
+ (wrap-program binary `("PATH" ":" prefix (,path))))
+ #t)))))
+ (inputs
+ `(("perl" ,perl)
+ ("python" ,python-2)
+ ("blast+" ,blast+)))
+ (home-page "http://www.bioinf.uni-leipzig.de/Software/proteinortho")
+ (synopsis "Detect orthologous genes across species")
+ (description
+ "Proteinortho is a tool to detect orthologous genes across different
+species. For doing so, it compares similarities of given gene sequences and
+clusters them to find significant groups. The algorithm was designed to handle
+large-scale data and can be applied to hundreds of species at once.")
+ (license license:gpl2+)))
+
(define-public pyicoteo
(package
(name "pyicoteo")