summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-01-13 08:58:00 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-01-13 08:58:00 +0100
commit1b4cb6288a141dba09c4148d5cf215cf7e2be43f (patch)
treeed7c6346d4c96f52923bde2226d95f5f95c688f3
parent291a85b29b166200dcc5bd2ff69af5e13ab68877 (diff)
downloadpatches-1b4cb6288a141dba09c4148d5cf215cf7e2be43f.tar
patches-1b4cb6288a141dba09c4148d5cf215cf7e2be43f.tar.gz
gnu: Add gupnp-av.
* gnu/packages/gnome.scm (gupnp-av): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/gnome.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d34d52b797..eae5b339c9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -397,6 +397,35 @@ for creating UPnP devices and control points, written in C using
(home-page "https://gitlab.gnome.org/GNOME/gupnp")
(license license:lgpl2.0+)))
+(define-public gupnp-av
+ (package
+ (name "gupnp-av")
+ (version "0.12.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1p3grslwqm9bc8rmpn4l48d7v9s84nina4r9xbd932dbj8acz7b8"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
+ ("libxml" ,libxml2)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("gupnp" ,gupnp)))
+ (synopsis "GUPnP A/V for GNOME")
+ (description "This package provides a small library for handling
+and implementation of UPnP A/V profiles.")
+ (home-page "https://gitlab.gnome.org/GNOME/gupnp-av")
+ (license license:lgpl2.0+)))
+
(define-public libmediaart
(package
(name "libmediaart")