summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2019-09-16 18:18:06 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-25 15:49:42 +0200
commit195854a50ce8e9abe15db24b4808f78fe52ce620 (patch)
tree3d1791af4739ab4534eae7a0f1a32cb20c96ee7b
parent34e624a56ad42f93d8526f7c7e2025d26a4cba5e (diff)
downloadpatches-195854a50ce8e9abe15db24b4808f78fe52ce620.tar
patches-195854a50ce8e9abe15db24b4808f78fe52ce620.tar.gz
gnu: Add r-assertable.
* gnu/packages/cran.scm (r-assertable): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cb0be4aedd..89a581cb5e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15610,3 +15610,30 @@ deprecated, and defunct). It makes it easy to insert badges corresponding to
these stages in your documentation. Usage of deprecated functions are
signalled with increasing levels of non-invasive verbosity.")
(license license:gpl3)))
+
+(define-public r-assertable
+ (package
+ (name "r-assertable")
+ (version "0.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "assertable" version))
+ (sha256
+ (base32
+ "0jjd6ylh26fykzzv1q2lbajzfj07lyxwb3b3xmr2zdg2fp5b2w4c"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-data-table" ,r-data-table)))
+ (home-page "https://cran.r-project.org/web/packages/assertable/")
+ (synopsis "Verbose assertions for tabular data (data.frames and data.tables)")
+ (description "This package provides simple, flexible assertions on
+data.frame or data.table objects with verbose output for vetting. While other
+assertion packages apply towards more general use-cases, @code{assertable} is
+tailored towards tabular data. It includes functions to check variable names
+and values, whether the dataset contains all combinations of a given set of
+unique identifiers, and whether it is a certain length. In addition,
+@code{assertable} includes utility functions to check the existence of target
+files and to efficiently import multiple tabular data files into one
+data.table.")
+ (license license:gpl3)))