summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-07-19 17:17:35 +0200
committerLudovic Courtès <ludo@gnu.org>2019-07-20 01:32:17 +0200
commitddc586ea5c1fd65e29d626c54da1d192c71b6750 (patch)
treeb7408a039baa0b100eb83c2d4d9154b8feb3b914
parentdd9560a050ed99952046a2bbd99dc6b331100c63 (diff)
downloadpatches-ddc586ea5c1fd65e29d626c54da1d192c71b6750.tar
patches-ddc586ea5c1fd65e29d626c54da1d192c71b6750.tar.gz
gnu: python-jupyter-client: Patch file name of 'ip'.
* gnu/packages/python-xyz.scm (python-jupyter-client)[arguments]: Add #:phases. [inputs]: New field.
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3852f5b1ee..6e90c9a933 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5122,7 +5122,19 @@ without using the configuration machinery.")
;; Tests fail because of missing native python kernel which I assume is
;; provided by the ipython package, which we cannot use because it would
;; cause a dependency cycle.
- (arguments `(#:tests? #f))
+ (arguments
+ `(#:tests? #f
+
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'set-tool-file-names
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((iproute (assoc-ref inputs "iproute")))
+ (substitute* "jupyter_client/localinterfaces.py"
+ (("'ip'")
+ (string-append "'" iproute "/sbin/ip'")))
+ #t))))))
+ (inputs
+ `(("iproute" ,iproute)))
(propagated-inputs
`(("python-pyzmq" ,python-pyzmq)
("python-traitlets" ,python-traitlets)