summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-29 13:13:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-29 15:05:23 +0300
commitc08f789d4df408bc299e0847e0c83bcfab7f6879 (patch)
treea307e9c79dcfe134e56c96d3424ec290842fd367
parent5913e06a75b06f0cb07b4309f0dd0cd19c84f320 (diff)
downloadpatches-c08f789d4df408bc299e0847e0c83bcfab7f6879.tar
patches-c08f789d4df408bc299e0847e0c83bcfab7f6879.tar.gz
gnu: Add rust-heapsize.
* gnu/packages/crates-io.scm (rust-heapsize): New variable.
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cd8a1b062a..f5b03b1df6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -499,6 +499,32 @@ featuring zero allocations, composability, and iterator-like interfaces.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-heapsize
+ (package
+ (name "rust-heapsize")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "heapsize" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0q94q9ppqjgrw71swiyia4hgby2cz6dldp7ij57nkvhd6zmfcy8n"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-winapi" ,rust-winapi))
+ ;; Tests assume rust is built with jemalloc.
+ ;; https://github.com/servo/heapsize/issues/74
+ #:cargo-test-flags '("--features" "flexible-tests")))
+ (home-page "https://github.com/servo/heapsize")
+ (synopsis "Measure the total runtime size of an object on the heap")
+ (description
+ "Infrastructure for measuring the total runtime size of an object on the
+heap.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-hex
(package
(name "rust-hex")