summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-10-10 10:47:15 +0300
committerAlex Kost <alezost@gmail.com>2015-10-14 19:20:59 +0300
commit6159943851d32e0396f96a4b3fc5e31b500cc8a6 (patch)
treecd87a6998224408531b77dfa2edc5bc9ac43560e
parent17fa842b79503dfa9972f3bfa3d5a96610263378 (diff)
downloadpatches-6159943851d32e0396f96a4b3fc5e31b500cc8a6.tar
patches-6159943851d32e0396f96a4b3fc5e31b500cc8a6.tar.gz
gnu: abbaye: Use 'sdl-union'.
* gnu/packages/games.scm (abbaye)[inputs]: Use 'sdl-union'. [arguments]: Adjust 'set-sdl-paths' phase accordingly.
-rw-r--r--gnu/packages/games.scm21
1 files changed, 5 insertions, 16 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e250bf9633..dfaf8388d1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -163,17 +163,10 @@ scriptable with Guile.")
(guix build utils))
#:phases (modify-phases %standard-phases
(add-after 'set-paths 'set-sdl-paths
- (lambda* (#:key inputs outputs (search-paths '())
- #:allow-other-keys)
- (define input-directories
- (match inputs
- (((_ . dir) ...)
- dir)))
- ;; This package does not use pkg-config, so modify CPATH
- ;; variable to point to include/SDL for SDL header files.
- (set-path-environment-variable "CPATH"
- '("include/SDL")
- input-directories)))
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CPATH"
+ (string-append (assoc-ref inputs "sdl-union")
+ "/include/SDL"))))
(add-after 'patch-source-shebangs 'patch-makefile
(lambda* (#:key outputs #:allow-other-keys)
;; Replace /usr with package output directory.
@@ -192,11 +185,7 @@ scriptable with Guile.")
(delete 'configure))
#:tests? #f)) ;; No check target.
(native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("sdl" ,sdl)
- ("sdl-gfx" ,sdl-gfx)
- ("sdl-image" ,sdl-image)
- ("sdl-mixer" ,sdl-mixer)
- ("sdl-ttf" ,sdl-ttf)))
+ (inputs `(("sdl-union" ,(sdl-union))))
(home-page "http://code.google.com/p/abbaye-for-linux/")
(synopsis "GNU/Linux port of the indie game \"l'Abbaye des Morts\"")
(description "L'Abbaye des Morts is a 2D platform game set in 13th century