summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-03-02 13:48:28 +0100
committerAndreas Enge <andreas@enge.fr>2014-03-02 13:48:28 +0100
commitfc1e45160e40c846f2f332d3552b314b912d3055 (patch)
tree187656d6346a37bb2cadd7090a21d00b2807a6f2
parentdc91c10f2bc21982f26a9f90721f23b79b5668b7 (diff)
downloadpatches-fc1e45160e40c846f2f332d3552b314b912d3055.tar
patches-fc1e45160e40c846f2f332d3552b314b912d3055.tar.gz
gnu: Add neon.
* gnu/packages/version-control.scm (neon): New variable.
-rw-r--r--gnu/packages/version-control.scm54
1 files changed, 52 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 3d69eee5cd..39d37a7645 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,13 +26,15 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build utils)
- #:use-module (gnu packages gettext)
#:use-module (gnu packages apr)
#:use-module (gnu packages curl)
#:use-module (gnu packages ed)
+ #:use-module (gnu packages gettext)
+;; #:use-module (gnu packages gnutls)
#:use-module (gnu packages nano)
#:use-module (gnu packages openssl)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages admin)
@@ -216,6 +218,54 @@ It efficiently handles projects of any size
and offers an easy and intuitive interface.")
(license gpl2+)))
+(define-public neon
+ (package
+ (name "neon")
+ (version "0.30.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.webdav.org/neon/neon-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1hlhg5w505jxdvaf7bq17057f6a48dry981g7lp2gwrhbp5wyqi9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxml2" ,libxml2)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (arguments
+ `(;; FIXME: Add tests once reverse address lookup is fixed in glibc, see
+ ;; https://sourceware.org/bugzilla/show_bug.cgi?id=16475
+ #:tests? #f
+ #:configure-flags '("--enable-shared"
+ ;; requires libgnutils-config, deprecated
+ ;; in gnutls 2.8.
+ ; "--with-ssl=gnutls")))
+ "--with-ssl=openssl")))
+ (home-page "http://www.webdav.org/neon/")
+ (synopsis "HTTP and WebDAV client library")
+ (description "Neon is an HTTP and WebDAV client library, with a
+C interface. Features:
+High-level wrappers for common HTTP and WebDAV operations (GET, MOVE,
+DELETE, etc.);
+low-level interface to the HTTP request/response engine, allowing the use
+of arbitrary HTTP methods, headers, etc.;
+authentication support including Basic and Digest support, along with
+GSSAPI-based Negotiate on Unix, and SSPI-based Negotiate/NTLM on Win32;
+SSL/TLS support using OpenSSL or GnuTLS, exposing an abstraction layer for
+verifying server certificates, handling client certificates, and examining
+certificate properties, smartcard-based client certificates are also
+supported via a PKCS#11 wrapper interface;
+abstract interface to parsing XML using libxml2 or expat, and wrappers for
+simplifying handling XML HTTP response bodies;
+WebDAV metadata support, wrappers for PROPFIND and PROPPATCH to simplify
+property manipulation.")
+ (license gpl2+))) ; for documentation and tests; source under lgpl2.0+
+
(define-public subversion
(package
(name "subversion")