summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-06 21:42:51 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-06 21:42:51 +0200
commit3dc67e38946b2784b2162335e9de1afd17d0d21e (patch)
treef57e578d6f1cab1706c1041a0e5fe19fbe53bacc
parent9fe8a4ba4e6c13aba810bf03015e466518417c45 (diff)
downloadpatches-3dc67e38946b2784b2162335e9de1afd17d0d21e.tar
patches-3dc67e38946b2784b2162335e9de1afd17d0d21e.tar.gz
gnu: Add libetonyek.
* gnu/packages/libreoffice.scm (libetonyek): New variable.
-rw-r--r--gnu/packages/libreoffice.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 71bd94e8ad..3e5f331fdb 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -260,3 +260,30 @@ AbiWord documents.")
(description "Libcdr is a library that parses the file format of
CorelDRAW documents of all versions.")
(license mpl2.0)))
+
+(define-public libetonyek
+ (package
+ (name "libetonyek")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
+ name "-" version ".tar.xz"))
+ (sha256 (base32
+ "0gn8v24jb9r9kxppbws6xlc7knpd9mk2n9xjvziccv5f2l7mlslw"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("cppunit" ,cppunit)
+ ("doxygen" ,doxygen)
+ ("gperf" ,gperf)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("boost" ,boost)
+ ("librevenge" ,librevenge)
+ ("libxml2" ,libxml2)))
+ (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libetonyek")
+ (synopsis "Library for parsing the Apple Keynote format")
+ (description "Libetonyek is a library that parses the file format of
+Apple Keynote documents. It currently supports Keynote versions 2 to 5.")
+ (license mpl2.0)))