summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 18:22:51 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commitfb35b7c0889f6b6f19edfc2ba26b9a97572638d3 (patch)
treeb8aecf73dd7a63634c7f91b24eadc52657ed47e2
parent3580ab8be2a8d3eaae078e31fec902150ad2fdb0 (diff)
downloadpatches-fb35b7c0889f6b6f19edfc2ba26b9a97572638d3.tar
patches-fb35b7c0889f6b6f19edfc2ba26b9a97572638d3.tar.gz
gnu: Add python-pygments.
* gnu/packages/python.scm (python-pygments, python2-pygments): New variables.
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f2d1f90b89..f012a8d801 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1780,3 +1780,28 @@ reStructuredText.")
(define-public python2-docutils
(package-with-python2 python-docutils))
+
+(define-public python-pygments
+ (package
+ (name "python-pygments")
+ (version "1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/P/Pygments/Pygments-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1h11r6ss8waih51vcksfvzghfxiav2f8svc0812fa5kmyz5d97kr"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://pygments.org/")
+ (synopsis "Syntax highlighting")
+ (description
+ "Pygments is a syntax highlighting package written in Python.")
+ (license bsd-2)))
+
+(define-public python2-pygments
+ (package-with-python2 python-pygments))