summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-12-01 00:04:22 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-01 11:28:48 +0100
commitf8446df663fecb5aa34e5c6dfa477544d3271d1e (patch)
treebda04070751344f06d2bf2c64cbb2be4e7129e60
parent1776d5cd184402895ec420d916a7171a2052c473 (diff)
downloadpatches-f8446df663fecb5aa34e5c6dfa477544d3271d1e.tar
patches-f8446df663fecb5aa34e5c6dfa477544d3271d1e.tar.gz
gnu: elogind: Remove "uaccess" tag usage in "seat-late" rules.
* gnu/packages/freedesktop.scm (elogind)[arguments]: Add 'remove-uaccess-tag' phase.
-rw-r--r--gnu/packages/freedesktop.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 9b6d7fa111..fa77fe2649 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -278,7 +278,16 @@ the freedesktop.org XDG Base Directory specification.")
(substitute* (string-append out "/lib/libelogind.la")
(("-lcap")
(string-append "-L" libcap "/lib -lcap")))
- #t))))))
+ #t)))
+ (add-after 'unpack 'remove-uaccess-tag
+ (lambda _
+ ;; systemd supports a "uaccess" built-in tag, but eudev currently
+ ;; doesn't. This leads to eudev warnings that we'd rather not
+ ;; see, so remove the reference to "uaccess."
+ (substitute* "src/login/73-seat-late.rules.in"
+ (("^TAG==\"uaccess\".*" line)
+ (string-append "# " line "\n")))
+ #t)))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)