summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-14 13:31:49 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-20 13:06:01 +0800
commiteea3e54c59564b78c2bf7c0b140f6b3682635a0d (patch)
tree20f86273267f12db98b1bbec5ddeeebd74b4cb8c
parentea57378f242a2c768691ff49dc1c6f7c53281587 (diff)
downloadpatches-eea3e54c59564b78c2bf7c0b140f6b3682635a0d.tar
patches-eea3e54c59564b78c2bf7c0b140f6b3682635a0d.tar.gz
gnu: Add xfce4-terminal.
* gnu/packages/xfce.scm (xfce4-terminal): New variable.
-rw-r--r--gnu/packages/xfce.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index b2954ff083..2b15c3e35c 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -512,3 +512,33 @@ on the screen.")
optional application menu or icons for minimized applications or launchers,
devices and folders.")
(license gpl2+)))
+
+(define-public xfce4-terminal
+ (package
+ (name "xfce4-terminal")
+ (version "0.6.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/apps/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "023y0lkfijifh05yz8grimxadqpi98mrivr00sl18nirq8b4fbwi"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("libxfce4ui" ,libxfce4ui)
+ ("vte" ,vte/gtk+-2)))
+ (home-page "http://www.xfce.org/")
+ (synopsis "Xfce terminal emulator")
+ (description
+ "A lightweight and easy to use terminal emulator for Xfce. Features
+include a simple configuration interface, the ability to use multiple tabs
+with terminals within a single window, the possibility to have a
+pseudo-transparent terminal background, and a compact mode (where both the
+menubar and the window decorations are hidden) that helps you to save space
+on your desktop.")
+ (license gpl2+)))