summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-05-26 14:45:39 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-05-26 14:56:43 +0200
commite91c29a491267a832b2739a8f171e6e1bf263a95 (patch)
treeebeac45c04a8b8804e974e4347a0c107c0ab1842
parent51bd1f5b07415f63cb5d402a73187855550858b4 (diff)
downloadpatches-e91c29a491267a832b2739a8f171e6e1bf263a95.tar
patches-e91c29a491267a832b2739a8f171e6e1bf263a95.tar.gz
* gnu/packages/lisp.scm (txr): Update to 238. [arguments]: Don't hardcode "cc=gcc" in configure-flags.
-rw-r--r--gnu/packages/lisp.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 3ae8dab141..21e1a0449b 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -806,7 +806,7 @@ enough to play the original mainframe Zork all the way through.")
(define-public txr
(package
(name "txr")
- (version "235")
+ (version "238")
(source
(origin
(method git-fetch)
@@ -815,12 +815,15 @@ enough to play the original mainframe Zork all the way through.")
(commit (string-append "txr-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0kpqk2x0sz7sqxsrhasq0xnljjlnxwhh4xjx2nii0zy2jkv4vsbn"))))
+ (base32 "0asdq4n828xb1m31s7f47mqcbjqkzxz11bwnw8v3f2249m93ync4"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags
- (list "cc=gcc"
- (string-append "--prefix=" (assoc-ref %outputs "out")))
+ `(#:configure-flags
+ (let ((target ,(%current-target-system)))
+ (list (string-append "cc=" (if target
+ (string-append target "-gcc")
+ "gcc"))
+ (string-append "--prefix=" (assoc-ref %outputs "out"))))
#:test-target "tests"
#:phases
(modify-phases %standard-phases