summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-18 22:28:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-22 18:56:35 +0200
commite441fc564bf3192b677289e4e16c6845c5c4f043 (patch)
tree1cb051991679b10af41ecc0fef0ad81639995388
parent8bbd0408408c43af6d40cb4935878985321077c7 (diff)
downloadpatches-e441fc564bf3192b677289e4e16c6845c5c4f043.tar
patches-e441fc564bf3192b677289e4e16c6845c5c4f043.tar.gz
gnu: ant: Implement in terms of ant/java8.
* gnu/packages/java.scm (ant): Inherit from ant/java8.
-rw-r--r--gnu/packages/java.scm62
1 files changed, 15 insertions, 47 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 19d8d67e52..b422a1effe 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1645,53 +1645,6 @@ IcedTea build harness.")
(define-public icedtea icedtea-7)
-(define-public ant
- (package (inherit ant-bootstrap)
- (name "ant")
- ;; The 1.9.x series is the last that can be built with GCJ. The 1.10.x
- ;; series requires Java 8.
- (version "1.9.9")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://apache/ant/source/apache-ant-"
- version "-src.tar.gz"))
- (sha256
- (base32
- "1k28mka0m3isy9yr8gz84kz1f3f879rwaxrd44vdn9xbfwvwk86n"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (for-each delete-file
- (find-files "lib/optional" "\\.jar$"))
- #t))))
- (arguments
- (substitute-keyword-arguments (package-arguments ant-bootstrap)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'remove-scripts
- ;; Remove bat / cmd scripts for DOS as well as the antRun and runant
- ;; wrappers.
- (lambda _
- (for-each delete-file
- (find-files "src/script"
- "(.*\\.(bat|cmd)|runant.*|antRun.*)"))
- #t))
- (replace 'build
- (lambda _
- (setenv "JAVA_HOME" (string-append (assoc-ref %build-inputs "gcj")
- "/lib/jvm"))
- ;; Disable tests to avoid dependency on hamcrest-core, which needs
- ;; Ant to build. This is necessary in addition to disabling the
- ;; "check" phase, because the dependency on "test-jar" would always
- ;; result in the tests to be run.
- (substitute* "build.xml"
- (("depends=\"jars,test-jar\"") "depends=\"jars\""))
- (zero? (system* "bash" "bootstrap.sh"
- (string-append "-Ddist.dir="
- (assoc-ref %outputs "out"))))))))))
- (native-inputs
- `(("gcj" ,gcj)))))
-
(define-public ant/java8
(package (inherit ant-bootstrap)
(name "ant")
@@ -1737,6 +1690,21 @@ IcedTea build harness.")
(native-inputs
`(("jdk" ,icedtea-8 "jdk")))))
+;; The 1.9.x series is the last that can be built with GCJ. The 1.10.x series
+;; requires Java 8.
+(define-public ant
+ (package (inherit ant/java8)
+ (version "1.9.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://apache/ant/source/apache-ant-"
+ version "-src.tar.gz"))
+ (sha256
+ (base32
+ "1k28mka0m3isy9yr8gz84kz1f3f879rwaxrd44vdn9xbfwvwk86n"))))
+ (native-inputs
+ `(("jdk" ,icedtea-7 "jdk")))))
+
(define-public clojure
(let* ((remove-archives '(begin
(for-each delete-file