summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-18 22:39:50 -0400
committerLeo Famulari <leo@famulari.name>2016-10-19 13:01:31 -0400
commitdef6213f6561001ec35a5536d09537ea61440d97 (patch)
tree2bf6e9fe2f011f3277713d66477cfd8f77aaa4f1
parent6de9dfce80b1afd9d934925938661048c3526b03 (diff)
downloadpatches-def6213f6561001ec35a5536d09537ea61440d97.tar
patches-def6213f6561001ec35a5536d09537ea61440d97.tar.gz
gnu: Add libseccomp.
* gnu/packages/linux.scm (libseccomp): New variable.
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 08fd7ac9bb..2d82093371 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3018,3 +3018,28 @@ of flash storage.")
(list license:gpl2 ; Almost everything is gpl2 or gpl2+
license:mpl1.1 ; All ftl* files
license:expat)))) ; libiniparser
+
+(define-public libseccomp
+ (package
+ (name "libseccomp")
+ (version "2.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/seccomp/libseccomp/"
+ "releases/download/v" version
+ "/libseccomp-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0asnlkzqms520r0dra08dzcz5hh6hs7lkajfw9wij3vrd0hxsnzz"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("which" ,which)))
+ (synopsis "Interface to Linux's seccomp syscall filtering mechanism")
+ (description "The libseccomp library provides an easy to use, platform
+independent, interface to the Linux Kernel's syscall filtering mechanism. The
+libseccomp API is designed to abstract away the underlying BPF based syscall
+filter language and present a more conventional function-call based filtering
+interface that should be familiar to, and easily adopted by, application
+developers.")
+ (home-page "https://github.com/seccomp/libseccomp")
+ (license license:lgpl2.1)))