summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Sprang <scs@stevesprang.com>2015-08-19 15:33:04 -0700
committerMark H Weaver <mhw@netris.org>2015-08-20 00:53:30 -0400
commitde63b20ed1753221161c4ec7b1e032d2141cc38c (patch)
tree50b6f8301c7ca7ccc764d2cc53165b4e10e21c09
parent0d2794005caa627965fd6256f28f94e36cd4b5a0 (diff)
downloadpatches-de63b20ed1753221161c4ec7b1e032d2141cc38c.tar
patches-de63b20ed1753221161c4ec7b1e032d2141cc38c.tar.gz
gnu: Add pwgen.
* gnu/packages/password-utils.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/password-utils.scm43
2 files changed, 44 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 147abfc0d6..aca0144abd 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -239,6 +239,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/ots.scm \
gnu/packages/package-management.scm \
gnu/packages/parallel.scm \
+ gnu/packages/password-utils.scm \
gnu/packages/patchutils.scm \
gnu/packages/pciutils.scm \
gnu/packages/pcre.scm \
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
new file mode 100644
index 0000000000..4aef371615
--- /dev/null
+++ b/gnu/packages/password-utils.scm
@@ -0,0 +1,43 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages password-utils)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module (guix packages))
+
+(define-public pwgen
+ (package
+ (name "pwgen")
+ (version "2.07")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/pwgen/pwgen-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0mhmw700kkh238fzivcwnwi94bj9f3h36yfh3k3j2v19b0zmjx7b"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test suite
+ (home-page "http://pwgen.sourceforge.net/")
+ (synopsis "Password generator")
+ (description "Pwgen generates passwords which can be easily memorized by a
+human.")
+ (license license:gpl2)))