summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-19 08:50:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-19 08:50:35 +0100
commitdd0568a77951804d97884a0a0a3a3ed38ca0a184 (patch)
tree75b5bfcb64e0e3477a725a93ed85eda327c52d44
parent142cd4dc98ed439f32d2a903ff866ae345234c0f (diff)
parentbaab9eef27994575e3ce1ba7efb822725600f748 (diff)
downloadpatches-dd0568a77951804d97884a0a0a3a3ed38ca0a184.tar
patches-dd0568a77951804d97884a0a0a3a3ed38ca0a184.tar.gz
Merge branch 'master' into core-updates
-rw-r--r--build-aux/build-self.scm3
-rw-r--r--doc/guix.texi2
-rw-r--r--gnu/packages/admin.scm4
-rw-r--r--gnu/packages/cran.scm4
-rw-r--r--gnu/packages/databases.scm4
-rw-r--r--gnu/packages/dns.scm4
-rw-r--r--gnu/packages/emacs-xyz.scm2
-rw-r--r--gnu/packages/gnome.scm15
-rw-r--r--gnu/packages/gpodder.scm2
-rw-r--r--gnu/packages/image-viewers.scm4
-rw-r--r--gnu/packages/jrnl.scm2
-rw-r--r--gnu/packages/linux.scm8
-rw-r--r--gnu/packages/lisp-xyz.scm4
-rw-r--r--gnu/packages/mail.scm12
-rw-r--r--gnu/packages/messaging.scm8
-rw-r--r--gnu/packages/music.scm10
-rw-r--r--gnu/packages/networking.scm5
-rw-r--r--gnu/packages/ocaml.scm10
-rw-r--r--gnu/packages/python-xyz.scm24
-rw-r--r--gnu/packages/tls.scm19
-rw-r--r--gnu/packages/version-control.scm9
-rw-r--r--gnu/packages/video.scm4
-rw-r--r--gnu/packages/web.scm4
-rw-r--r--gnu/packages/webkit.scm8
24 files changed, 102 insertions, 69 deletions
diff --git a/build-aux/build-self.scm b/build-aux/build-self.scm
index b30adfeb9f..b6a69a46e9 100644
--- a/build-aux/build-self.scm
+++ b/build-aux/build-self.scm
@@ -286,7 +286,8 @@ interface (FFI) of Guile.")
#:select? select?))
(gexp->script "compute-guix-derivation"
#~(begin
- (use-modules (ice-9 match))
+ (use-modules (ice-9 match)
+ (ice-9 threads))
(eval-when (expand load eval)
;; (gnu packages …) modules are going to be looked up
diff --git a/doc/guix.texi b/doc/guix.texi
index d1fa8d033a..c2eff582f8 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -1597,7 +1597,7 @@ $ export GUIX_LOCPATH=$HOME/.guix-profile/lib/locale
Note that the @code{glibc-locales} package contains data for all the
locales supported by the GNU@tie{}libc and weighs in at around
-110@tie{}MiB. Alternatively, the @code{glibc-utf8-locales} is smaller but
+917@tie{}MiB. Alternatively, the @code{glibc-utf8-locales} is smaller but
limited to a few UTF-8 locales.
The @code{GUIX_LOCPATH} variable plays a role similar to @code{LOCPATH}
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 3d24e039d7..45d4a513c8 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3234,7 +3234,7 @@ Python loading in HPC environments.")
(let ((real-name "inxi"))
(package
(name "inxi-minimal")
- (version "3.0.37-1")
+ (version "3.0.38-1")
(source
(origin
(method git-fetch)
@@ -3243,7 +3243,7 @@ Python loading in HPC environments.")
(commit version)))
(file-name (git-file-name real-name version))
(sha256
- (base32 "15wvj9w601ci3bavd1hk5qlm8dfm7a7cjglczk29yir5yw2jww3f"))))
+ (base32 "1qw3sxgd3ly916bzzl3873s3flngwd3vh57slw0shsj7ivz8bfnm"))))
(build-system trivial-build-system)
(inputs
`(("bash" ,bash-minimal)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8426285b7a..75e9afcac5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5617,7 +5617,7 @@ using the @code{snow} package.")
(build-system r-build-system)
(propagated-inputs
`(("r-snow" ,r-snow)))
- (home-page "http://cran.r-project.org/web/packages/snowfall/")
+ (home-page "https://cran.r-project.org/web/packages/snowfall/")
(synopsis "Easier cluster computing")
(description "This package is a usability wrapper around snow for easier
development of parallel R programs. This package offers e.g. extended error
@@ -15473,7 +15473,7 @@ path of values for the regularization parameter.")
"0iwc06blr5sx7rylwczi2jrha8sk8qs0jklflwpidl0zj1jxdggp"))))
(properties `((upstream-name . "RhpcBLASctl")))
(build-system r-build-system)
- (home-page "http://prs.ism.ac.jp/~nakama/Rhpc/")
+ (home-page "https://prs.ism.ac.jp/~nakama/Rhpc/")
(synopsis "Control the number of threads on BLAS")
(description
"This package allows you to control the number of threads the BLAS
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index e6cdbf03d5..0c097a3383 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1140,7 +1140,7 @@ including field and record folding.")))
(define-public rocksdb
(package
(name "rocksdb")
- (version "6.6.4")
+ (version "6.7.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1149,7 +1149,7 @@ including field and record folding.")))
(file-name (git-file-name name version))
(sha256
(base32
- "1h7y31b05w4vv4v509l368j9qlbv5assmdq9hp2788zipqbpywc0"))
+ "19nacd7fb98i97ir07jjsk3l1vf7zzq04c4nqywizq8wakcx99s9"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index a5948beb81..bccc971109 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -124,7 +124,7 @@ and BOOTP/TFTP for network booting of diskless machines.")
(define-public isc-bind
(package
(name "bind")
- (version "9.16.0")
+ (version "9.16.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -132,7 +132,7 @@ and BOOTP/TFTP for network booting of diskless machines.")
"/bind-" version ".tar.xz"))
(sha256
(base32
- "0a1f1wrlbnmq79q6s15fny36ip81malg6wlr8acp7amimsyxjjxg"))))
+ "14ayswxnyaqwb935iqdi1w9ih3zs0a0va59j4cyi5f9mh7kxf4x9"))))
(build-system gnu-build-system)
(outputs `("out" "utils"))
(inputs
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 479c10049e..acd690fee5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21779,7 +21779,7 @@ All entries in a specified TODO state will be carried over to the next day.")
"Simple Org mode based static blog generator")
(description
"@code{emacs-org-static-blog} is one more static blog generator, it
-focuses on being simple. All file are simple Org files in a directory. The
+focuses on being simple. All files are simple Org files in a directory. The
only requirement is that every Org file must have a @samp{title} and
a @samp{date} keywords, and optionally, a @samp{filetags} keyword.")
(license license:bsd-3)))
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3aa192bfd3..f0b4d01e3d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3675,7 +3675,7 @@ libxml to ease remote use of the RESTful API.")
(define-public libsoup
(package
(name "libsoup")
- (version "2.68.4")
+ (version "2.70.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libsoup/"
@@ -3683,7 +3683,7 @@ libxml to ease remote use of the RESTful API.")
"libsoup-" version ".tar.xz"))
(sha256
(base32
- "151j5dc84gbl6a917pxvd0b372lw5za48n63lyv6llfc48lv2l1d"))))
+ "0hjk9lgppc5435my0lyywbpmj7ib5vvcylwfin8ki97g9bvj1c2l"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
@@ -3798,7 +3798,7 @@ and the GLib main loop, to integrate well with GNOME applications.")
(define-public libsecret
(package
(name "libsecret")
- (version "0.20.1")
+ (version "0.20.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3807,7 +3807,7 @@ and the GLib main loop, to integrate well with GNOME applications.")
"libsecret-" version ".tar.xz"))
(sha256
(base32
- "0ir4ynpf8b64xss1azvsi5x6697lik7hkf3z0xxa2qv2xja3xxsp"))))
+ "1hzz34gmsxxf1jm1b7qin390rkwbg8sx198xdkwxqp3q6cw19sc1"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(arguments
@@ -9258,7 +9258,7 @@ configurable file renaming. ")
(define-public workrave
(package
(name "workrave")
- (version "1.10.34")
+ (version "1.10.37")
(source
(origin
(method git-fetch)
@@ -9269,8 +9269,11 @@ configurable file renaming. ")
version)))))
(file-name (git-file-name name version))
(sha256
- (base32 "0czwhr7nw523753ajcjjfwrf91mq8pmzr19gp0srqsvb1dsn1zcf"))))
+ (base32 "01cxy7606hx9wgxl550l4p2xa9hsy0rk7swsp58hyi842z2z0y13"))))
(build-system glib-or-gtk-build-system)
+ (arguments
+ ;; The only tests are maintainer tests (in po/), which fail.
+ `(#:tests? #f))
(inputs `(("glib" ,glib)
("gtk+" ,gtk+)
("gdk-pixbuf" ,gdk-pixbuf)
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 8e7c961929..8bf69c6551 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -127,7 +127,7 @@ locally for later listening.")
;; TODO: Enable tests when https://github.com/gpodder/gpodder/issues/446
;; is fixed.
#:tests? #f))
- (home-page "http://wiki.gpodder.org/wiki/Libmygpo-qt")
+ (home-page "https://gpodder.github.io")
(synopsis "Qt/C++ library wrapping the gpodder web service")
(description "@code{libmygpo-qt} is a Qt/C++ library wrapping the
@url{https://gpodder.net} APIs. It allows applications to discover, manage
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index ad5251fc0c..5587bad675 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -508,14 +508,14 @@ preloading.")
(define-public chafa
(package
(name "chafa")
- (version "1.2.1")
+ (version "1.2.2")
(source (origin
(method url-fetch)
(uri (string-append "https://hpjansson.org/chafa/releases/chafa-"
version ".tar.xz"))
(sha256
(base32
- "1hj4vdyczby8h52ff23qxl8ng18p5jy549idngpiddwszf5s4drz"))))
+ "0aa7119514rhsak5i0kgvwllb9z74lnfzfn7dzfhs27fc8cvx1dg"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/jrnl.scm b/gnu/packages/jrnl.scm
index e5e2a4ba4f..5b57cc7c9b 100644
--- a/gnu/packages/jrnl.scm
+++ b/gnu/packages/jrnl.scm
@@ -55,7 +55,7 @@
("python-six" ,python-six)
("python-dateutil" ,python-dateutil)
("python-parsedatetime" ,python-parsedatetime)))
- (home-page "http://maebert.github.io/jrnl/")
+ (home-page "https://maebert.github.io/jrnl/")
(synopsis "Personal journal application")
(description
"Jrnl is a command line journal application that stores your journal in a
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 03cbe48866..2c0674c338 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -362,18 +362,18 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
"linux-" version ".tar.xz"))
(sha256 hash)))
-(define-public linux-libre-5.4-version "5.4.25")
+(define-public linux-libre-5.4-version "5.4.26")
(define-public linux-libre-5.4-pristine-source
(let ((version linux-libre-5.4-version)
- (hash (base32 "09ay0adc3s3m7qk0nj5lkmrp5i0q76a9kax0xix8914d115rgvf0")))
+ (hash (base32 "1bqdiw4pjzwm7pxml2dl09bj85ijs82rq788c58681zgmvs796k6")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.4)))
-(define-public linux-libre-4.19-version "4.19.110")
+(define-public linux-libre-4.19-version "4.19.111")
(define-public linux-libre-4.19-pristine-source
(let ((version linux-libre-4.19-version)
- (hash (base32 "15kbgj13vsr74c61vzs96a72k86x205jjq5bz9pbn70698n3s4fa")))
+ (hash (base32 "0cjjf3wbvbkjy4mss8c74afx8ng31i22km66ydh9f9mz182piyy6")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.19)))
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index e6bb85eaed..ae7057ca3f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3008,7 +3008,7 @@ is a library for creating graphical user interfaces.")
(sbcl-package->cl-source-package sbcl-cl-cffi-gtk))
(define-public sbcl-cl-webkit
- (let ((commit "79ad41996a1bd7fc8e53fe8d168e8f2030603b14"))
+ (let ((commit "4832c99c31e0eb1fcce3779d119343ae8a423952"))
(package
(name "sbcl-cl-webkit")
(version (git-version "2.4" "1" commit))
@@ -3021,7 +3021,7 @@ is a library for creating graphical user interfaces.")
(file-name (git-file-name "cl-webkit" version))
(sha256
(base32
- "1gxvmxmss5k79v2ccigx92q46zbydxh9r7plnnqh8na348pffgcs"))))
+ "0sn7m181wfg1q49q45dlsry8c38x7pziqcs0frnymk6yvgndybxd"))))
(build-system asdf-build-system/sbcl)
(inputs
`(("cffi" ,sbcl-cffi)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 94bd81fb33..6be6662057 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -430,7 +430,7 @@ operating systems.")
(define-public neomutt
(package
(name "neomutt")
- (version "20191207")
+ (version "20200313")
(source
(origin
(method git-fetch)
@@ -439,7 +439,7 @@ operating systems.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "147yjpqnsbfy01fhsflxlixk0985r91a6bjmqq3cwmf7gka3sihm"))))
+ (base32 "1k4k07l6h5krc3fx928qvdq3ssw9fxn95aj7k885xlckd2i1lnb5"))))
(build-system gnu-build-system)
(inputs
`(("cyrus-sasl" ,cyrus-sasl)
@@ -1391,6 +1391,7 @@ facilities for checking incoming mail.")
`(("pkg-config" ,pkg-config)))
(inputs
`(("bzip2" ,bzip2)
+ ("libsodium" ,libsodium) ; extra password algorithms
("linux-pam" ,linux-pam)
("lz4" ,lz4)
("openssl" ,openssl)
@@ -1398,7 +1399,8 @@ facilities for checking incoming mail.")
("zlib" ,zlib)))
(arguments
`(#:configure-flags '("--sysconfdir=/etc"
- "--localstatedir=/var")
+ "--localstatedir=/var"
+ "--with-sqlite") ; not auto-detected
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-file-names
@@ -1512,8 +1514,8 @@ using libsodium sealed boxes.
(home-page "https://github.com/LuckyFellow/dovecot-libsodium-plugin")
(synopsis "Libsodium password hashing schemes plugin for Dovecot")
(description
- "@code{dovecot-libsodium-plugin} provides libsodium password
-hashing schemes plugin for @code{Dovecot}.")
+ "@code{dovecot-libsodium-plugin} provides a libsodium password
+hashing scheme (such as scrypt) plug-in for @code{Dovecot}.")
(license gpl3+))))
(define-public isync
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 4ce210392e..ccb2be7c41 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1280,7 +1280,7 @@ into existing applications.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://perlpsyc.psyc.eu/"
+ (uri (string-append "https://perl.psyc.eu/"
"perlpsyc-" version ".zip"))
(file-name (string-append name "-" version ".zip"))
(sha256
@@ -1339,10 +1339,10 @@ into existing applications.")
(description
"@code{Net::PSYC} with support for TCP, UDP, Event.pm, @code{IO::Select} and
Gtk2 event loops. This package includes 12 applications and additional scripts:
-psycion (a @uref{http://about.psyc.eu,PSYC} chat client), remotor (a control console
+psycion (a @uref{https://about.psyc.eu,PSYC} chat client), remotor (a control console
for @uref{https://torproject.org,tor} router) and many more.")
(synopsis "Perl implementation of PSYC protocol")
- (home-page "http://perlpsyc.psyc.eu/")
+ (home-page "https://perl.psyc.eu")
(license (list license:gpl2
license:perl-license
;; contrib/irssi-psyc.pl:
@@ -1378,7 +1378,7 @@ for @uref{https://torproject.org,tor} router) and many more.")
;; therefore we do not include them.
;; TODO: Get a cargo build system in Guix.
(delete 'configure)))) ; no configure script
- (home-page "http://about.psyc.eu/libpsyc")
+ (home-page "https://about.psyc.eu/libpsyc")
(description
"@code{libpsyc} is a PSYC library in C which implements
core aspects of PSYC, useful for all kinds of clients and servers
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1277353e45..db50fbf9a9 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -754,7 +754,7 @@ MusePack, Monkey's Audio, and WavPack files.")
("emacs" ,emacs-no-x)))
;; Extempore refuses to build on architectures other than x86_64
(supported-systems '("x86_64-linux"))
- (home-page "http://digego.github.io/extempore/")
+ (home-page "https://digego.github.io/extempore/")
(synopsis "Programming environment for live coding of multimedia")
(description
"Extempore is a programming language and runtime environment designed
@@ -1040,7 +1040,7 @@ Guile.")
("ntk" ,ntk)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://non.tuxfamily.org/wiki/Non%20Sequencer")
+ (home-page "https://non.tuxfamily.org/wiki/Non%20Sequencer")
(synopsis "Pattern-based MIDI sequencer")
(description
"The Non Sequencer is a powerful, lightweight, real-time,
@@ -1064,7 +1064,7 @@ transport is rolling.")
("ntk" ,ntk)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://non.tuxfamily.org/nsm/")
+ (home-page "https://non.tuxfamily.org/nsm/")
(synopsis "Audio session management")
(description
"The Non Session Manager is an API and an implementation for audio
@@ -1088,7 +1088,7 @@ communicate with the session management daemon.")
("ntk" ,ntk)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://non.tuxfamily.org/wiki/Non%20Mixer")
+ (home-page "https://non.tuxfamily.org/wiki/Non%20Mixer")
(synopsis "Modular digital audio mixer")
(description
"The Non Mixer is a powerful, reliable and fast modular digital audio
@@ -1113,7 +1113,7 @@ studio.")
("ntk" ,ntk)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://non.tuxfamily.org/wiki/Non%20Timeline")
+ (home-page "https://non.tuxfamily.org/wiki/Non%20Timeline")
(synopsis "Modular digital audio timeline arranger")
(description
"The Non Timeline is a powerful, reliable and fast modular digital audio
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5c7c7eba2e..8083a43fdb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -899,15 +899,14 @@ live network and disk I/O bandwidth monitor.")
(define-public aircrack-ng
(package
(name "aircrack-ng")
- (version "1.5.2")
+ (version "1.6")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.aircrack-ng.org/aircrack-ng-"
version ".tar.gz"))
(sha256
- (base32
- "0hc2x17bxk2n00z8jj5jfwq3z41681fd19n018724il0cpkjyncy"))))
+ (base32 "0ix2k64qg7x3w0bzdsbk1m50kcpq1ws59g3zkwiafvpwdr4gs2sg"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 35701039ad..c9a1037902 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -570,7 +570,7 @@ Git-friendly development workflow.")
(install-file "etc/META" (string-append (assoc-ref outputs "out")
"/lib/ocaml/camlp5/"))
#t)))))
- (home-page "http://camlp5.gforge.inria.fr/")
+ (home-page "https://camlp5.github.io/")
(synopsis "Pre-processor Pretty Printer for OCaml")
(description
"Camlp5 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
@@ -764,16 +764,16 @@ Knuth’s LR(1) parser construction technique.")
(define-public lablgtk
(package
(name "lablgtk")
- (version "2.18.8")
+ (version "2.18.10")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/garrigue/lablgtk")
- (commit "lablgtk2188")))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "0gpww8bkwi5cl68kc006970zvzwvq73h1mwrnd239apmwlxc1l8a"))))
+ "0w8cdfcv2wc19sd3qzj3qq77qc6rbnbynsz02gzbl15kgrvgrfxi"))))
(build-system gnu-build-system)
(native-inputs
`(("ocaml" ,ocaml)
@@ -1038,7 +1038,7 @@ other XUnit testing frameworks.")
(list "all" "allopt"
(string-append "INSTALLDIR=" (assoc-ref %outputs "out")
"/lib/ocaml"))))
- (home-page "http://forge.ocamlcore.org/projects/camlzip")
+ (home-page "https://github.com/xavierleroy/camlzip")
(synopsis "Provides easy access to compressed files")
(description "Provides easy access to compressed files in ZIP, GZIP and
JAR format. It provides functions for reading from and writing to compressed
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 945b89fe80..c20ef40192 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3685,6 +3685,18 @@ writing C extensions for Python as easy as Python itself.")
(substitute-keyword-arguments (package-arguments base)
((#:phases phases)
`(modify-phases ,phases
+ ;; XXX: On i686-linux, running the parallel tests fails on many-core
+ ;; systems, see <https://github.com/cython/cython/issues/2807>.
+ ;; TODO: Move this logic to the regular check phase in a future
+ ;; rebuild cycle.
+ ,@(if (string-prefix? "i686" (%current-system))
+ '((replace 'check
+ (lambda _
+ (setenv "CFLAGS" "-O0")
+ (invoke "python" "runtests.py" "-vv"
+ "-j" (number->string (parallel-job-count))
+ "-x" "run.parallel"))))
+ '())
(add-before 'check 'adjust-test_embed
(lambda _
(substitute* "runtests.py"
@@ -12028,16 +12040,16 @@ command @command{natsort} that exposes this functionality in the command line.")
`(("python2-pathlib" ,python2-pathlib)
,@(package-native-inputs base))))))
-(define-public python-glances
+(define-public glances
(package
- (name "python-glances")
- (version "3.1.2")
+ (name "glances")
+ (version "3.1.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Glances" version))
(sha256
- (base32 "15384pbvw9wj4sb8zgvd9v1812vrypbyjg0acicjf1hdb3p30fkk"))
+ (base32 "0dc47gbvp9a3wxppdqihxpglxxaxbj3hcvzgcxxq8zcsciah3plq"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -12061,8 +12073,8 @@ Glances uses the PsUtil library to get information from your system. It
monitors CPU, load, memory, network bandwidth, disk I/O, disk use, and more.")
(license license:lgpl3+)))
-(define-public python2-glances
- (package-with-python2 python-glances))
+(define-public python-glances
+ (deprecated-package "python-glances" glances))
(define-public python-graphql-core
(package
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index ce8abfb9a2..45ee67fa9c 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -281,6 +281,7 @@ required structures.")
(package
(name "openssl")
(version "1.1.1d")
+ (replacement openssl-1.1.1e)
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -402,6 +403,24 @@ required structures.")
(license license:openssl)
(home-page "https://www.openssl.org/")))
+(define openssl-1.1.1e
+ (package
+ (inherit openssl)
+ (version "1.1.1e")
+ (source (origin
+ (method url-fetch)
+ (uri (list (string-append "https://www.openssl.org/source/openssl-"
+ version ".tar.gz")
+ (string-append "ftp://ftp.openssl.org/source/"
+ "openssl-" version ".tar.gz")
+ (string-append "ftp://ftp.openssl.org/source/old/"
+ (string-trim-right version char-set:letter)
+ "/openssl-" version ".tar.gz")))
+ (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
+ (sha256
+ (base32
+ "1gnwlri1dphr5wdzmg9vlhkh6aq2yqgpfkpmffzwjlfb26n62kv9"))))))
+
(define-public openssl-1.0
(package
(inherit openssl)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c0f8130de4..ac2a849705 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -154,14 +154,14 @@ as well as the classic centralized workflow.")
(name "git")
;; XXX When updating Git, check if the special 'git-source' input to cgit
;; needs to be updated as well.
- (version "2.25.1")
+ (version "2.25.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "09lzwa183nblr6l8ib35g2xrjf9wm9yhk3szfvyzkwivdv69c9r2"))))
+ "08vivrv3my8nlp40pwsf7mcc5k7dwyh34hadjszx7qj8w01p34wv"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -178,7 +178,7 @@ as well as the classic centralized workflow.")
version ".tar.xz"))
(sha256
(base32
- "15pfm7j4wq8ryp9n9d81h8v0arl15yq9i6cigw45walnq5r6721h"))))
+ "06nlw6vaqvavkr4nia9qvanqbhaig4hbg9r5f0i9lbvw1hmykfvq"))))
;; For subtree documentation.
("asciidoc" ,asciidoc-py3)
("docbook-xsl" ,docbook-xsl)
@@ -239,9 +239,6 @@ as well as the classic centralized workflow.")
#:test-target "test"
- ;; Tests fail randomly when parallel: <https://bugs.gnu.org/29512>.
- #:parallel-tests? #f
-
;; The explicit --with-tcltk forces the build system to hardcode the
;; absolute file name to 'wish'.
#:configure-flags (list (string-append "--with-tcltk="
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d18944fcbd..861e5c427e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3701,7 +3701,7 @@ transitions, and effects and then export your film to many common formats.")
(define-public dav1d
(package
(name "dav1d")
- (version "0.5.2")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
@@ -3709,7 +3709,7 @@ transitions, and effects and then export your film to many common formats.")
"/dav1d/" version "/dav1d-" version ".tar.xz"))
(sha256
(base32
- "02hgarv2x2bqbac15pdj7pbm8f4lyn78ws0dncygvhis9a6ghk7r"))))
+ "0w5k572jzxp7zwdbsa0jgjzri6hsrkydawzzilrw46nxpcak37q9"))))
(build-system meson-build-system)
(native-inputs `(("nasm" ,nasm)))
(home-page "https://code.videolan.org/videolan/dav1d")
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5d0da82ec7..171e83650e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5482,13 +5482,13 @@ deployments.")
(package
(name "varnish")
(home-page "https://varnish-cache.org/")
- (version "6.3.2")
+ (version "6.4.0")
(source (origin
(method url-fetch)
(uri (string-append home-page "_downloads/varnish-" version ".tgz"))
(sha256
(base32
- "1f5ahzdh3am6fij5jhiybv3knwl11rhc5r3ig1ybzw55ai7788q8"))))
+ "1hkn98vbxk7rc1sd08367qn6rcv8wkxgwbmm1x46y50vi0nvldpn"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib")
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 808790e0a5..3c0cfa2b89 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -64,14 +64,14 @@
(define-public libwpe
(package
(name "libwpe")
- (version "1.4.0")
+ (version "1.6.0")
(source (origin
(method url-fetch)
(uri (string-append "https://wpewebkit.org/releases/libwpe-"
version ".tar.xz"))
(sha256
(base32
- "1221vs72zs87anrzhbm6pf8jnii7s6ms7mkzj6nlds9zqd7lklz2"))))
+ "141w35b488jjhanl3nrm0awrbcy6hb579fk8n9vbpx07m2wcd1rm"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ;no tests
@@ -93,14 +93,14 @@ backend which implements them.")
(define-public wpebackend-fdo
(package
(name "wpebackend-fdo")
- (version "1.4.2")
+ (version "1.6.0")
(source (origin
(method url-fetch)
(uri (string-append "https://wpewebkit.org/releases/"
"wpebackend-fdo-" version ".tar.xz"))
(sha256
(base32
- "07wd736d4nhd2vpxnjzv9pb8firvbn11jmdbnhpkhjxbxa1k86pw"))))
+ "0rzm16m3mw9dh2jis9avk2rhz7bijanrzlywyiaicyzrv2wxfnvz"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ;no tests