summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 16:49:16 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:29 -0600
commitd4dfe333dfcd906019f63172a27c8f984fd804e6 (patch)
tree2c1110620507e8428c9e6b27a7722e7b686fb95c
parent800e13d26530439f00d08aee37822326c9104047 (diff)
downloadpatches-d4dfe333dfcd906019f63172a27c8f984fd804e6.tar
patches-d4dfe333dfcd906019f63172a27c8f984fd804e6.tar.gz
gnu: Add Test-Most.
* gnu/packages/perl.scm (perl-test-most): New variable.
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4315650bc0..1cea293b52 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1460,6 +1460,32 @@ testing exception-throwing code with about the same amount of typing.")
automatically aggregated and output to STDOUT.")
(license (package-license perl))))
+(define-public perl-test-most
+ (package
+ (name "perl-test-most")
+ (version "0.34")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/O/OV/OVID/"
+ "Test-Most-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0i72aih3pakm8gh73wx1n4dwq8lbx6dvxhla46gsapszws6hr0n2"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-test-differences" ,perl-test-differences)
+ ("perl-test-warn" ,perl-test-warn)
+ ("perl-exception-class" ,perl-exception-class)
+ ("perl-test-deep" ,perl-test-deep)
+ ("perl-test-exception" ,perl-test-exception)))
+ (home-page "http://search.cpan.org/dist/Test-Most")
+ (synopsis "Most commonly needed test functions and features")
+ (description "This module provides the most commonly used testing
+functions, along with automatically turning on strict and warning and gives a
+bit more fine-grained control over test suites.")
+ (license (package-license perl))))
+
(define-public perl-test-nowarnings
(package
(name "perl-test-nowarnings")