summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-04-10 13:54:25 +0100
committerChristopher Baines <mail@cbaines.net>2020-05-26 09:02:06 +0100
commitc4b0131010c7bb864198318fc44b10b038c80b55 (patch)
treeccebd6fd4076b79f2e2de4f6e6a085789ca04ccc
parentcf7381612c3bf2fd89fd03a53e85ed6eb9e9f9f8 (diff)
downloadpatches-c4b0131010c7bb864198318fc44b10b038c80b55.tar
patches-c4b0131010c7bb864198318fc44b10b038c80b55.tar.gz
gnu: python2-dogtail: Switch to Python 3, and add Python 2 variant.
* gnu/packages/python-xyz.scm (python2-dogtail): Rename to python-dogtail. [name]: Change python2-dogtail to python-dogtail. [arguments]: Remove #:python. [propagated-inputs,native-inputs]: Switch Python 2 packages to Python 3 variants. (python2-dogtail): New variable.
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0cbb5e81e3..b359ffc955 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1748,11 +1748,9 @@ Python 3.3+.")
(define-public python2-pyicu
(package-with-python2 python-pyicu))
-(define-public python2-dogtail
- ;; Python 2 only, as it leads to "TabError: inconsistent use of tabs and
- ;; spaces in indentation" with Python 3.
+(define-public python-dogtail
(package
- (name "python2-dogtail")
+ (name "python-dogtail")
(version "0.9.11")
(source (origin
(method url-fetch)
@@ -1765,8 +1763,7 @@ Python 3.3+.")
"0sr38z7b2n12bvfd4xw4b5dnnhkn5zl3h0ymmnnzavcihfqia6l0"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2
- #:tests? #f ; TODO Launching dbus for the tests
+ `(#:tests? #f ; TODO Launching dbus for the tests
; fails
#:phases
(modify-phases %standard-phases
@@ -1778,11 +1775,11 @@ Python 3.3+.")
(invoke "dbus-run-session" "--" "nosetests" "-v" "tests/"))
#t)))))
(propagated-inputs
- `(("python-pygobject" ,python2-pygobject)
- ("python-pycairo" ,python2-pycairo)
- ("python-pyatspi" ,python2-pyatspi)))
+ `(("python-pygobject" ,python-pygobject)
+ ("python-pycairo" ,python-pycairo)
+ ("python-pyatspi" ,python-pyatspi)))
(native-inputs
- `(("python-nose" ,python2-nose)
+ `(("python-nose" ,python-nose)
("gtk+" ,gtk+)
("xvfb" ,xorg-server)
("dbus" ,dbus)
@@ -1797,6 +1794,9 @@ applications. dogtail scripts are written in Python and executed like any
other Python program.")
(license license:gpl2+)))
+(define-public python2-dogtail
+ (package-with-python2 python-dogtail))
+
(define-public python-empy
(package
(name "python-empy")