summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-04-01 22:39:44 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-04-19 20:27:27 -0400
commitc0c0bb3823418812c999472bc6334bfa454f148a (patch)
tree85010cf2281283b542661ac238916681fb37d64f
parentd5a998fa4c9023115563b3a4b7bb24e95a6e9bdc (diff)
downloadpatches-c0c0bb3823418812c999472bc6334bfa454f148a.tar
patches-c0c0bb3823418812c999472bc6334bfa454f148a.tar.gz
gnu: Add python-rellu.
* gnu/packages/python-xyz.scm (python-rellu): New variable.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 36edd7e0e2..bebb7c5cb2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2729,6 +2729,29 @@ repositories, user profiles, and organizations in your Python applications,
using version 3 of the GitHub application programming interface (API).")
(license license:lgpl3+)))
+(define-public python-rellu
+ (package
+ (name "python-rellu")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rellu" version))
+ (sha256
+ (base32
+ "1w0arpj1sm7vh29nrbnca4pnp8sx42l07r17inwqcjjf9bhng66x"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-invoke" ,python-invoke)
+ ("python-pygithub" ,python-pygithub)))
+ (home-page "https://github.com/robotframework/rellu")
+ (synopsis "Utilities to create PyPI releases")
+ (description "This collection of utilities contains tooling and templates
+to assist in creating releases on GitHub and publishing them on PyPI. It is
+designed to be used by Robot Framework and tools and libraries in its
+ecosystem, but can naturally be used also by other projects.")
+ (license license:asl2.0)))
+
(define-public python-scp
(package
(name "python-scp")