summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-11-23 15:41:30 +0100
committerAndreas Enge <andreas@enge.fr>2014-11-23 15:46:06 +0100
commitbc0b89bb3eca3adf35230d1fe7f89664762be4e8 (patch)
tree56cff94b41e40ed10560bc70b98164e34e8fddfb
parentaf89a6673522a0260f04ae503b53813c053ca26f (diff)
downloadpatches-bc0b89bb3eca3adf35230d1fe7f89664762be4e8.tar
patches-bc0b89bb3eca3adf35230d1fe7f89664762be4e8.tar.gz
gnu: xf86-video-openchrome: Patch to correct build failure.
* gnu/packages/xorg.scm (xf86-video-openchrome): Add patch for build failure with glibc-2.20. Fixes bug #18740. * gnu/packages/patches/xf86-video-openchrome-includes.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/xf86-video-openchrome-includes.patch35
-rw-r--r--gnu/packages/xorg.scm3
3 files changed, 38 insertions, 1 deletions
diff --git a/gnu-system.am b/gnu-system.am
index d3b822c169..4c9fcda8b9 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -435,6 +435,7 @@ dist_patch_DATA = \
gnu/packages/patches/vpnc-script.patch \
gnu/packages/patches/w3m-fix-compile.patch \
gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch \
+ gnu/packages/patches/xf86-video-openchrome-includes.patch \
gnu/packages/patches/xmodmap-asprintf.patch
bootstrapdir = $(guilemoduledir)/gnu/packages/bootstrap
diff --git a/gnu/packages/patches/xf86-video-openchrome-includes.patch b/gnu/packages/patches/xf86-video-openchrome-includes.patch
new file mode 100644
index 0000000000..3c79596387
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-openchrome-includes.patch
@@ -0,0 +1,35 @@
+This follows the same rationale as xf86-input-synaptics-glibc-2.20.patch
+to allow building with glibc-2.20.
+diff -u -r xf86-video-openchrome-0.2.906.old/src/via_3d.h xf86-video-openchrome-0.2.906/src/via_3d.h
+--- xf86-video-openchrome-0.2.906.old/src/via_3d.h 2014-11-23 14:04:58.000000000 +0100
++++ xf86-video-openchrome-0.2.906/src/via_3d.h 2014-11-23 14:18:37.000000000 +0100
+@@ -24,6 +24,7 @@
+ #ifndef VIA_3D_H
+ #define VIA_3D_H
+
++#include "xorg-server.h"
+ #include "xf86.h"
+ #include "via_dmabuffer.h"
+
+diff -u -r xf86-video-openchrome-0.2.906.old/src/via_driver.h xf86-video-openchrome-0.2.906/src/via_driver.h
+--- xf86-video-openchrome-0.2.906.old/src/via_driver.h 2014-11-23 14:04:58.000000000 +0100
++++ xf86-video-openchrome-0.2.906/src/via_driver.h 2014-11-23 14:21:43.000000000 +0100
+@@ -35,6 +35,7 @@
+ #endif
+
+ #include "vgaHW.h"
++#include "xorg-server.h"
+ #include "xf86.h"
+
+ #if GET_ABI_MAJOR(ABI_VIDEODRV_VERSION) < 6
+diff -u -r xf86-video-openchrome-0.2.906.old/src/via_timing.h xf86-video-openchrome-0.2.906/src/via_timing.h
+--- xf86-video-openchrome-0.2.906.old/src/via_timing.h 2014-11-23 14:04:58.000000000 +0100
++++ xf86-video-openchrome-0.2.906/src/via_timing.h 2014-11-23 14:20:50.000000000 +0100
+@@ -25,6 +25,7 @@
+ #ifndef _TIMING_H_
+ #define _TIMING_H_
+
++#include "xorg-server.h"
+ #include "xf86.h"
+
+ /* Aspect ratio not CVT standard */
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 41c6a03932..292845c64e 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2843,7 +2843,8 @@ kernel mode setting (KMS).")
".tar.bz2"))
(sha256
(base32
- "0hgzn1r7ig94xbr9dvq0bp1nxqlfp2ki8823jca3f22a2kf8wmg7"))))
+ "0hgzn1r7ig94xbr9dvq0bp1nxqlfp2ki8823jca3f22a2kf8wmg7"))
+ (patches (list (search-patch "xf86-video-openchrome-includes.patch")))))
(build-system gnu-build-system)
(inputs `(("libx11" ,libx11)
("libxext" ,libxext)