summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-01-19 12:28:55 +0100
committerAndreas Enge <andreas@enge.fr>2013-01-19 12:28:55 +0100
commitb387a1c5b21fc56752b5ce5e4e992bac0580006a (patch)
tree3a07e4ec7b7597c935e8bfcbaf0659a098c5ad7a
parent8f86331a22d92ade6f9357d3d1f65be524f7ccbc (diff)
downloadpatches-b387a1c5b21fc56752b5ce5e4e992bac0580006a.tar
patches-b387a1c5b21fc56752b5ce5e4e992bac0580006a.tar.gz
gnu: Add Freetype.
licenses: Add freetype license. * gnu/packages/freetype.scm: New file. * guix/licenses.scm (freetype): New variable. * Makefile.am (MODULES): Add freetype.scm.
-rw-r--r--Makefile.am1
-rw-r--r--gnu/packages/freetype.scm46
-rw-r--r--guix/licenses.scm6
3 files changed, 53 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 416c35cc2e..3e9cae44fb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,7 @@ MODULES = \
gnu/packages/emacs.scm \
gnu/packages/file.scm \
gnu/packages/flex.scm \
+ gnu/packages/freetype.scm \
gnu/packages/gawk.scm \
gnu/packages/gdb.scm \
gnu/packages/gdbm.scm \
diff --git a/gnu/packages/freetype.scm b/gnu/packages/freetype.scm
new file mode 100644
index 0000000000..70144ab7e0
--- /dev/null
+++ b/gnu/packages/freetype.scm
@@ -0,0 +1,46 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages freetype)
+ #:use-module (gnu packages)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public freetype
+ (package
+ (name "freetype")
+ (version "2.4.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://download.savannah.gnu.org/releases/freetype/freetype-"
+ version ".tar.gz"))
+ (sha256 (base32
+ "0gpcz6swir64kp0dk3rwgqqkmf48b90dqgczdmznjjryhrahx9r9"))))
+ (build-system gnu-build-system)
+ (synopsis "Freetype, a library to render fonts")
+ (description
+ "Freetype is a library that can be used by applications to access the
+contents of font files. It provides a uniform interface to access font files.
+It supports both bitmap and scalable formats, including TrueType, OpenType,
+Type1, CID, CFF, Windows FON/FNT, X11 PCF, and others. It supports high-speed
+anti-aliased glyph bitmap generation with 256 gray levels.")
+ (license freetype) ; some files have other licenses
+ (home-page "http://www.freetype.org/")))
diff --git a/guix/licenses.scm b/guix/licenses.scm
index 58eb7218c5..93af865055 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -28,6 +28,7 @@
cpl1.0
epl1.0
expat
+ freetype
gpl1 gpl1+ gpl2 gpl2+ gpl3 gpl3+
ijg
ibmpl1.0
@@ -111,6 +112,11 @@ which may be a file:// URI pointing the package's tree."
"http://directory.fsf.org/wiki/License:Expat"
"https://www.gnu.org/licenses/license-list.html#Expat"))
+(define freetype
+ (license "Freetype"
+ "http://directory.fsf.org/wiki/License:Freetype"
+ "https://www.gnu.org/licenses/license-list.html#freetype"))
+
(define gpl1
(license "GPL 1"
"https://www.gnu.org/licenses/old-licenses/gpl-1.0.html"