summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-04-01 22:39:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-04-19 10:56:47 -0400
commitb24fd2c268ee5c89c10b1195a791502c84d5d329 (patch)
tree210ce1cfc085468b0444e9be4bb8ea0815598faf
parent13d825fcb60ada8579f8ec9663a121ab88c5fb68 (diff)
downloadpatches-b24fd2c268ee5c89c10b1195a791502c84d5d329.tar
patches-b24fd2c268ee5c89c10b1195a791502c84d5d329.tar.gz
gnu: Add python-deprecated.
* gnu/packages/python-xyz.scm (python-deprecated): New variable.
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9ac01e76c8..c1014a9a6e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2649,6 +2649,40 @@ and several other projects.")
software version simply.")
(license license:expat)))
+(define-public python-deprecated
+ (package
+ (name "python-deprecated")
+ (version "1.2.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tantale/deprecated.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14909glxxwwc4b9qpz2b9jdriwzi5n65ichw85xqppap5f79wcwz"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest"))))))
+ (propagated-inputs
+ `(("python-wrapt" ,python-wrapt)))
+ (native-inputs
+ `(("python-bumpversion" ,python-bumpversion)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-sphinx" ,python-sphinx)
+ ("python-tox" ,python-tox)))
+ (home-page "https://github.com/tantale/deprecated")
+ (synopsis "Python decorator to deprecate classes, functions or methods")
+ (description "The @code{deprecated} decorator provides a convenient way to deprecate
+to deprecate classes, functions or methods.")
+ (license license:expat)))
+
(define-public python-scp
(package
(name "python-scp")