summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-02-07 08:38:32 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-26 23:45:41 +0100
commitaefcfecd84302ea5a3711c26d02395f8b25a354c (patch)
treef2a447ef31437bef902f5cffcbcb5272dd5006c7
parentbe6520e6a58d7f6ee58f4cab76db9d1245410113 (diff)
downloadpatches-aefcfecd84302ea5a3711c26d02395f8b25a354c.tar
patches-aefcfecd84302ea5a3711c26d02395f8b25a354c.tar.gz
gnu: Add python-pytest-check-links.
* gnu/packages/python-xyz.scm (python-pytest-check-links): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f4b50abb1d..209d8563d3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18676,3 +18676,31 @@ allows to start and stop daemons for a quick throw-away usage. This is typicall
useful when needing these daemons to run integration testing. It originally
evolved from its precursor @code{overtest}.")
(license license:asl2.0)))
+
+(define-public python-pytest-check-links
+ (package
+ (name "python-pytest-check-links")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ ;; URI uses underscores
+ (uri (pypi-uri "pytest_check_links" version))
+ (sha256
+ (base32
+ "12x3wmrdzm6wgk0vz02hb769h68nr49q47w5q1pj95pc89hsa34v"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-docutils" ,python-docutils)
+ ("python-html5lib" ,python-html5lib)
+ ("python-nbconvert" ,python-nbconvert)
+ ("python-nbformat" ,python-nbformat)
+ ("python-pytest" ,python-pytest)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-pbr-minimal" ,python-pbr-minimal)))
+ (home-page "https://github.com/minrk/pytest-check-links")
+ (synopsis "Check links in files")
+ (description "This package provides a pytest plugin that checks URLs for
+HTML-containing files.")
+ (license license:bsd-3)))