summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-15 21:45:07 -0400
committerLeo Famulari <leo@famulari.name>2016-10-19 13:12:48 -0400
commit94cffc6386d2f4d5e8246cf13149892f2c35bea5 (patch)
tree33762fe8293e83fb383fdbc615820dad0b40fc65
parente09f952d9f08f620b1921e7797c621e14eb637f8 (diff)
downloadpatches-94cffc6386d2f4d5e8246cf13149892f2c35bea5.tar
patches-94cffc6386d2f4d5e8246cf13149892f2c35bea5.tar.gz
gnu: Add python-s3transfer.
* gnu/packages/python.scm (python-s3transfer, python2-s3transfer): New variable.
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9153ad4dc2..a618dfe3b8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11058,3 +11058,34 @@ with an associated set of resolve methods that know how to fetch data.")
provide extendible implementations of common aspects of a cloud so that you can
focus on building massively scalable web applications.")
(license license:expat)))
+
+(define-public python-s3transfer
+ (package
+ (name "python-s3transfer")
+ (version "0.1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "s3transfer" version))
+ (sha256
+ (base32
+ "1jivjkp3xqif9gzr5fiq28jsskmh50vzzd7ldsb4rbyiw1iyv3hy"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-docutils" ,python-docutils)))
+ (inputs
+ `(("python-botocore" ,python-botocore)))
+ (synopsis "Amazon S3 Transfer Manager")
+ (description "S3transfer is a Python library for managing Amazon S3
+transfers.")
+ (home-page "https://github.com/boto/s3transfer")
+ (license license:asl2.0)
+ (properties `((python2-variant . ,(delay python2-s3transfer))))))
+
+(define-public python2-s3transfer
+ (let ((base (package-with-python2 (strip-python2-variant python-s3transfer))))
+ (package
+ (inherit base)
+ (native-inputs
+ `(("python2-futures" ,python2-futures)
+ ("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))