summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2019-05-17 13:42:12 -0400
committerLudovic Courtès <ludo@gnu.org>2019-05-22 00:09:42 +0200
commit8c141421fa43e885b56bbb88d26ccd8ff5348b00 (patch)
treea8d093b6afedc71250a1605126d2f1882d78bedc
parente7313ae2936dfc0b3627d06b79d24fba5c04e406 (diff)
downloadpatches-8c141421fa43e885b56bbb88d26ccd8ff5348b00.tar
patches-8c141421fa43e885b56bbb88d26ccd8ff5348b00.tar.gz
gnu: Add mallard-ducktype
* gnu/packages/python-xyz.scm: (mallard-ducktype) new variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5322b70759..1c337e0685 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
;;; Copyright © 2019 Sam <smbaines8@gmail.com>
+;;; Copyright © 2019 Jack Hill <jackhill@jackhill.us>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3224,6 +3225,32 @@ Markdown input files, and more. Pelican uses Jinja2 for templating
and is very extensible.")
(license license:agpl3+)))
+(define-public mallard-ducktype
+ (package
+ (name "mallard-ducktype")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ ;; git-reference because a proper source tarball is not available
+ ;; https://lists.gnu.org/archive/html/guix-devel/2019-05/msg00209.html
+ (uri (git-reference
+ (url "https://github.com/projectmallard/mallard-ducktype.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0crland0kmpsyjfmnflcw7gaqy5b87b6ah17cmr9d5z1kyazf54n"))))
+ (build-system python-build-system)
+ (home-page "http://projectmallard.org")
+ (synopsis "Convert Ducktype to Mallard documentation markup")
+ (description
+ "Ducktype is a lightweight syntax that can represent all the semantics
+of the Mallard XML documentation system. Ducktype files can be converted to
+Mallard using the @command{ducktype} tool. The yelp-tools package
+provides additional functionality on the produced Mallard documents.")
+ (license license:expat)))
+
(define-public python-scikit-image
(package
(name "python-scikit-image")