summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2016-10-16 16:19:32 +0200
committerFederico Beffa <beffa@fbengineering.ch>2016-10-19 08:44:11 +0200
commit725dddd7fba133b073a8434726734e16531d31f4 (patch)
treee8364b31806f789621b18fe06afff4131c723cd5
parentfb6d2d75f3166af28959aab63fd001bda8aa77bb (diff)
downloadpatches-725dddd7fba133b073a8434726734e16531d31f4.tar
patches-725dddd7fba133b073a8434726734e16531d31f4.tar.gz
gnu: Add ghc-storable-complex.
* gnu/packages/haskell.scm (ghc-storable-complex): New variable.
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 52e4bc3484..50b09efd02 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7598,4 +7598,25 @@ versions of these packages distributed with different versions of GHC.
In particular, this library supports working with POSIX files that have paths
which can't be decoded in the current locale encoding.")
(license license:expat)))
+
+(define-public ghc-storable-complex
+ (package
+ (name "ghc-storable-complex")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/storable-complex/storable-complex-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "01kwwkpbfjrv26vj83cd92px5qbq1bpgxj0r45534aksqhany1xb"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/cartazio/storable-complex")
+ (synopsis "Haskell Storable instance for Complex")
+ (description "This package provides a Haskell library including a
+Storable instance for Complex which is binary compatible with C99, C++
+and Fortran complex data types.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here