summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-09-04 18:21:19 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-04 18:21:19 +0200
commit6ef379f879a1d098ec55a9ca294e808e24291daf (patch)
treee3bbdd245a4aafcd7cfd41af3696e90c58461fd3
parent6202bb33eb9751778c7342f7673c64bfea7a1103 (diff)
downloadpatches-6ef379f879a1d098ec55a9ca294e808e24291daf.tar
patches-6ef379f879a1d098ec55a9ca294e808e24291daf.tar.gz
gnu: make-linux-libre: Fix cross-compilation.
* gnu/packages/linux.scm (make-linux-libre)[arguments]: Unset CROSS_CPATH to make sure that cross-libc is not found. Otherwise, some of its header would conflict with the one from linux (stdint.h and linux/types.h).
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7794debaab..890548e51b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -669,6 +669,12 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
#t))
(replace 'configure
(lambda* (#:key inputs native-inputs target #:allow-other-keys)
+ ;; Unset CROSS_CPATH to make sure that cross-libc is not
+ ;; found. Otherwise, some of its header would conflict with the
+ ;; one from linux (stdint.h and linux/types.h)
+ ,@(if (%current-target-system)
+ '((unsetenv "CROSS_CPATH"))
+ '())
;; Avoid introducing timestamps
(setenv "KCONFIG_NOTIMESTAMP" "1")
(setenv "KBUILD_BUILD_TIMESTAMP" (getenv "SOURCE_DATE_EPOCH"))