summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-29 12:47:23 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-01 20:29:32 +0100
commit6b520156c2fb30412ab7b187f6d65f2d7520e8c9 (patch)
tree924c7d263bec47a989aa880b09b309710b0becb4
parent5010d0e36452882eb95666467bb983efa8cca081 (diff)
downloadpatches-6b520156c2fb30412ab7b187f6d65f2d7520e8c9.tar
patches-6b520156c2fb30412ab7b187f6d65f2d7520e8c9.tar.gz
gnu: Add perl-test-command.
* gnu/packages/perl.scm (perl-test-command): New public variable.
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 0343b167ab..62df8f72c1 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7622,6 +7622,28 @@ namespace::autoclean or namespace::clean and are therefore available to be
called as methods, which usually isn't want you want.")
(license (package-license perl))))
+(define-public perl-test-command
+ (package
+ (name "perl-test-command")
+ (version "0.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DA/DANBOO/Test-Command-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0cwm3c4d49mdrbm6vgh78b3x8mk730l0zg8i7xb9z8bkx9pzr8r8"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (home-page "https://github.com/danboo/perl-test-command")
+ (synopsis "Test routines for external commands")
+ (description
+ "This module provides routines for testing the exit status, standard
+output and standard error of external commands.")
+ (license perl-license)))
+
(define-public perl-test-cpan-meta
(package
(name "perl-test-cpan-meta")