summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-11-25 17:30:32 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-25 23:44:20 +0100
commit6634180f9eabc70cdc5bc8e9ce2ff0f9250625bc (patch)
treedf5026e4f6ee76973b6002d9cad437f61f35fa39
parent7276b5604d863d1de4f932c3a2e29e0fedaa3005 (diff)
downloadpatches-6634180f9eabc70cdc5bc8e9ce2ff0f9250625bc.tar
patches-6634180f9eabc70cdc5bc8e9ce2ff0f9250625bc.tar.gz
gnu: guile-ssh: Update to 0.10.2.
* gnu/packages/ssh.scm (guile-ssh): Update to 0.10.2. [home-page]: Update. [source]: Use the 'url-fetch' method and a GitHub generated tarball. [arguments] <autoreconf>: Remove now unneeded 'chmod' call.
-rw-r--r--gnu/packages/ssh.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 5fdeeb74a4..ea5ec811d1 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -204,24 +204,24 @@ Additionally, various channel-specific options can be negotiated.")
(define-public guile-ssh
(package
(name "guile-ssh")
- (version "0.10.1")
+ (version "0.10.2")
+ (home-page "https://github.com/artyom-poptsov/guile-ssh")
(source (origin
;; ftp://memory-heap.org/software/guile-ssh/guile-ssh-VERSION.tar.gz
;; exists, but the server appears to be too slow and unreliable.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/artyom-poptsov/libguile-ssh.git")
- (commit (string-append "v" version))))
- (file-name (string-append name "-" version "-checkout"))
+ ;; Also, using this URL allows the GitHub updater to work.
+ (method url-fetch)
+ (uri (string-append home-page "/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0ky77kr7rnkhbq938bir61mlr8b86lfjcjjb1bxx1y1fhimsiz72"))))
+ "0pkiq3fm15pr4w1r420rrwwfmi4jz492r6l6vzjk6v73xlyfyfl3"))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
(add-after 'unpack 'autoreconf
(lambda* (#:key inputs #:allow-other-keys)
- (chmod "doc/version.texi" #o777) ;make it writable
(zero? (system* "autoreconf" "-vfi"))))
(add-before 'build 'fix-libguile-ssh-file-name
(lambda* (#:key outputs #:allow-other-keys)
@@ -255,7 +255,6 @@ Additionally, various channel-specific options can be negotiated.")
"Guile-SSH is a library that provides access to the SSH protocol for
programs written in GNU Guile interpreter. It is a wrapper to the underlying
libssh library.")
- (home-page "https://github.com/artyom-poptsov/libguile-ssh")
(license license:gpl3+)))
(define-public corkscrew