summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-25 22:33:31 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-25 22:38:00 +0300
commit6115ab1d2099b29097ac3c9988a82bb42a2c70aa (patch)
treecefd4f4a9d74a213248ed6b4643ffb7c2541f12f
parent062585711e324db35fff46592f8876ae00b6063b (diff)
downloadpatches-6115ab1d2099b29097ac3c9988a82bb42a2c70aa.tar
patches-6115ab1d2099b29097ac3c9988a82bb42a2c70aa.tar.gz
gnu: Add go-github-com-francoispqt-gojay.
* gnu/packages/golang.scm (go-github-com-francoispqt-gojay): New variable.
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3ae59ad2b7..8dd276562a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3141,6 +3141,31 @@ network protocol.")
(home-page "https://github.com/lucas-clemente/quic-go")
(license license:expat)))
+(define-public go-github-com-francoispqt-gojay
+ (package
+ (name "go-github-com-francoispqt-gojay")
+ (version "1.2.13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/francoispqt/gojay")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ix95qdyajfmxhf9y52vjrih63f181pjs4v5as8905s4d5vmkd06"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/francoispqt/gojay"))
+ (propagated-inputs
+ `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)))
+ (synopsis "JSON encoder/decoder with powerful stream API for Golang")
+ (description "GoJay is a performant JSON encoder/decoder for Golang. It has
+a simple API and doesn't use reflection. It relies on small interfaces to
+decode/encode structures and slices.")
+ (home-page "https://github.com/francoispqt/gojay")
+ (license license:expat)))
+
(define-public go-github-com-pkg-errors
(package
(name "go-github-com-pkg-errors")