summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-03-20 18:03:20 +0100
committerJakub Kądziołka <kuba@kadziolka.net>2020-03-26 22:53:02 +0100
commit60eee3e6de2a11b425496bbdf90bfe1f807c8f49 (patch)
tree0729d73e365187ee99a0957698bb5b8f5bf745c3
parenteebaed2b7662d514fa93cae753bc14451ba6814f (diff)
downloadpatches-60eee3e6de2a11b425496bbdf90bfe1f807c8f49.tar
patches-60eee3e6de2a11b425496bbdf90bfe1f807c8f49.tar.gz
gnu: Add ROPgadget.
* gnu/packages/cybersecurity.scm: New file. (ropgadget): New variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Register the file.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/cybersecurity.scm46
2 files changed, 47 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 07b159c4fe..0a406dffa0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -138,6 +138,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/cups.scm \
%D%/packages/curl.scm \
%D%/packages/cvassistant.scm \
+ %D%/packages/cybersecurity.scm \
%D%/packages/cyrus-sasl.scm \
%D%/packages/databases.scm \
%D%/packages/datamash.scm \
diff --git a/gnu/packages/cybersecurity.scm b/gnu/packages/cybersecurity.scm
new file mode 100644
index 0000000000..aedac03b8a
--- /dev/null
+++ b/gnu/packages/cybersecurity.scm
@@ -0,0 +1,46 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cybersecurity)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system python)
+ #:use-module (gnu packages engineering))
+
+(define-public ropgadget
+ (package
+ (name "ropgadget")
+ (version "6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ROPGadget" version))
+ (sha256
+ (base32
+ "0idiicgpijar9l9kqmfdh865c2mkfgxg0q7lpz77jc09l6q0afjh"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-capstone" ,python-capstone)))
+ (home-page "http://shell-storm.org/project/ROPgadget/")
+ (synopsis "Semiautomatic return oriented programming")
+ (description
+ "This tool lets you search for @acronym{ROP, Return Oriented Programming}
+gadgets in binaries. Some facilities are included for automatically generating
+chains of gadgets to execute system calls.")
+ (license license:bsd-3)))