summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2016-08-30 06:41:55 +0200
committerJohn Darrington <jmd@gnu.org>2016-08-30 07:00:59 +0200
commit594d740d7234bb5297f87b14ae0bf5785999ffbd (patch)
tree563eefd4fdb428edd2f24b318f7c7710e0c82e90
parent1da82dbb9901704316362943629a20b71ce7c912 (diff)
downloadpatches-594d740d7234bb5297f87b14ae0bf5785999ffbd.tar
patches-594d740d7234bb5297f87b14ae0bf5785999ffbd.tar.gz
gnu: Add libnfsidmap
* gnu/packages/linux.scm (libnfsidmap): New variable.
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 07fd6e5b74..ddabb399c4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Craven <david@craven.ch>
+;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -198,6 +199,30 @@
`insmod', `lsmod', and more.")
(license license:gpl2+)))
+(define-public libnfsidmap
+ (package
+ (name "libnfsidmap")
+ (version "0.25")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.citi.umich.edu/projects/nfsv4/linux/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1kzgwxzh83qi97rblcm9qj80cdvnv8kml2plz0q103j0hifj8vb5"))))
+ (build-system gnu-build-system)
+ (home-page
+ "http://www.citi.umich.edu/projects/nfsv4/crossrealm/libnfsidmap_config.html")
+ (synopsis
+ "NFSv4 support library for name/ID mapping")
+ (description "Libnfsidmap is a library holding mulitiple methods of
+mapping names to ids and visa versa, mainly for NFSv4. It provides an
+extensible array of mapping functions, currently consisting of two choices;
+the default @code{nsswitch} and the experimental @{umich_ldap}.")
+ (license (license:non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))))
+
(define %boot-logo-patch
;; Linux-Libre boot logo featuring Freedo and a gnu.
(origin