summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 16:28:54 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:28 -0600
commit54af5f55180f6544b573bc6830fe45425369015c (patch)
treea383297133e562c73fa0d967152e498981088814
parent42350bbe77bf0ef106f241f07cd2f5e2768e4b2d (diff)
downloadpatches-54af5f55180f6544b573bc6830fe45425369015c.tar
patches-54af5f55180f6544b573bc6830fe45425369015c.tar.gz
gnu: Add PadWalker.
* gnu/packages/perl.scm (perl-padwalker): New variable.
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 7b78f76650..48022d9f1d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -907,6 +907,27 @@ default if it's installed, and should be preferred in all environments with a
compiler.")
(license (package-license perl))))
+(define-public perl-padwalker
+ (package
+ (name "perl-padwalker")
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RO/ROBIN/"
+ "PadWalker-" version ".tar.gz"))
+ (sha256
+ (base32
+ "058l78rkr6px3rqcv2sdf9sqimdq1nc6py5yb9rrg3wmva7crw84"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/PadWalker")
+ (synopsis "Play with other peoples' lexical variables")
+ (description "PadWalker is a module which allows you to inspect (and even
+change) lexical variables in any subroutine which called you. It will only
+show those variables which are in scope at the point of the call. PadWalker
+is particularly useful for debugging.")
+ (license (package-license perl))))
+
(define-public perl-params-util
(package
(name "perl-params-util")