summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-17 15:12:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-17 15:13:57 +0200
commit5247aab8d6a18a4081ab7caeddb4fc083bca1f6b (patch)
tree1e02a97684e77d2b885196986f8cb81de1d460c8
parent7f080fb97c28fd94da1efaaa8fec8b5b830c328d (diff)
downloadpatches-5247aab8d6a18a4081ab7caeddb4fc083bca1f6b.tar
patches-5247aab8d6a18a4081ab7caeddb4fc083bca1f6b.tar.gz
gnu: multipath-tools: Treat libaio headers as system headers.
* gnu/packages/linux.scm (multipath-tools)[arguments]: Set C_INCLUDE_PATH in <#:make-flags>.
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4ccf613a9b..22f001d040 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3271,6 +3271,12 @@ arrays when needed.")
(string-append "DESTDIR="
(assoc-ref %outputs "out"))
"SYSTEMDPATH=lib"
+ ;; Add the libaio headers to GCCs system header
+ ;; search path to suppress -Werror=cast-qual on
+ ;; the included headers.
+ (string-append "C_INCLUDE_PATH="
+ (assoc-ref %build-inputs "libaio")
+ "/include")
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
"/lib"))