summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorleungbk <bkleung89@gmail.com>2019-02-18 03:32:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-18 22:05:48 +0100
commit48211de6dc9210718e69ba63a60c155cba043539 (patch)
treeff3b8d095c76cfb23c06c4884a71d682493a76c7
parentb49c8b9ef8a11f74f86db00a6d1360ab5068da12 (diff)
downloadpatches-48211de6dc9210718e69ba63a60c155cba043539.tar
patches-48211de6dc9210718e69ba63a60c155cba043539.tar.gz
gnu: Add emacs-isearch-prop.
* gnu/packages/emacs-xyz.scm (emacs-isearch-prop): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bd3c51b087..0b586738f4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9626,6 +9626,32 @@ until the top-level form is no longer a macro call.")
(description "Execute menu items as commands, with completion.")
(license license:gpl3)))
+(define-public emacs-isearch-prop
+ (let ((commit "5e9dc44cf582d998aaa73ccd4d07cbda01248156")
+ (revision "1"))
+ (package
+ (name "emacs-isearch-prop")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacsmirror/isearch-prop.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xawppy705ybsgx566zvj8zk2aajq0sqvhvfs7nijqq32lx0a2zl"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.emacswiki.org/emacs/isearch-prop.el")
+ (synopsis "Extensions to @code{isearch.el}")
+ (description "The Emacs library @code{isearch-prop.el} lets you search within
+ contexts. You can limit incremental search to a set of zones of
+ buffer text, search contexts that in effect constitute a multi-region.
+ These zones can be defined in various ways, including some ways
+ provided specially by this library.")
+ (license license:gpl3+))))
+
(define-public emacs-company-lua
(let ((commit "0be8122f3adf57ad27953bf4b03545d6298d3da4"))
(package