summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-05-05 00:06:32 +0200
committerAndreas Enge <andreas@enge.fr>2013-05-05 00:09:37 +0200
commit3a08a411887704ddce9f01336608fba4ba48db4d (patch)
tree26e578ae106936698dfb9d4226ea07b567a49bfd
parentfbd8445704bff083f6df90e2eed3311c2ce2ed06 (diff)
downloadpatches-3a08a411887704ddce9f01336608fba4ba48db4d.tar
patches-3a08a411887704ddce9f01336608fba4ba48db4d.tar.gz
gnu: Add atk.
* gnu/packages/gtk.scm: New module. * Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am1
-rw-r--r--gnu/packages/gtk.scm48
2 files changed, 49 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 43f8c3fb82..61d8bddf0e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -108,6 +108,7 @@ MODULES = \
gnu/packages/groff.scm \
gnu/packages/grub.scm \
gnu/packages/gsasl.scm \
+ gnu/packages/gtk.scm \
gnu/packages/guile.scm \
gnu/packages/help2man.scm \
gnu/packages/icu4c.scm \
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
new file mode 100644
index 0000000000..5dfe20f523
--- /dev/null
+++ b/gnu/packages/gtk.scm
@@ -0,0 +1,48 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gtk)
+ #:use-module ((guix licenses)
+ #:renamer (symbol-prefix-proc 'license:))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages pkg-config))
+
+(define-public atk
+ (package
+ (name "atk")
+ (version "2.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/atk/2.8/atk-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1x3dd3hg9l1j9dq70xwph13vxdp6a9wbfcnryryf1wr6c8bij9dj"))))
+ (build-system gnu-build-system)
+ (inputs `(("glib" ,glib)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "GNOME accessability toolkit")
+ (description
+ "ATK provides the set of accessibility interfaces that are implemented
+by other toolkits and applications. Using the ATK interfaces, accessibility
+tools have full access to view and control running applications.")
+ (license license:lgpl2.0+)
+ (home-page "https://developer.gnome.org/atk/")))